Ab 7007-c


#1

Hello all,
This is my first time programming and implementing the device listed above. I spoke with Kyle over the phone yesterday and have since built what I think is a proper design for our setup we are working with. We are connecting via Ethernet to a Control Logix L71 processor. we successfully loaded the correct EDS file yesterday with Kyles assistance. However, we cannot connect to PLC when in Run mode. I am trying to make sure we have the correct settings. Is anyone willing to help out with this configuration? I have tried to call this morning, however with being out of country for some reason I cannot connect to a LAN line anywhere in the States. Thank you in advance!!


#2

Hi Jeremy,

I just saw this and didn’t know if it was posted before or after I talked to you today. Did you get the wiring and config file done?

Kyle


#4

Kyle,

I do have the configuration done. However, the wiring is definitely a problem. We are having them change the wiring to a daisy chain configuration. It may take them a couple of days. Please see attached .cfg file. Let me know what you think. Now I just have to figure out how to initiate/process this info in our L71S controller.

Anybus CFG 07-30-19.cfg (16 KB)


#5

#6

Hi Jeremy,

It looks much better, no conflicts. The used memory is spaced out, but it should still work fine:

image

This is probably my fault, because when I was doing the first few as an example, I was using decimal and not hex. It should still work fine, but remember the values are in hex.

Let me know if you need any help after you get the wiring done.

Kyle


#7

Kyle,

I don’t guess I understand what you are saying about the used memory. I did notice there was a large gap in the responses. How can I fix this for optimal operation, or does it need to be fixed? I know you said it should work fine, with this being my first time setting something like this up, I want to make sure I have it absolutely correct. Thanks again Kyle!!


#8

Also,

I just noticed that my subnet is red. (transaction error timeout/subnet stopped). What are usually main issue with this red led?


#9

The values are in hex which is why there are those blank spots.

0 = 0x00 8 = 0x08 16 = 0x10 24 = 0x18 32 = 0x20 40 = 0x28 48 = 0x30 etc.

So I just fixed the first 3 nodes and it looks like this:

image

Anybus CFG 08-01-19.cfg (16.0 KB)

As far as LED 5 goes, this could be many things because it can be caused by a timeout or any number of different transaction errors. I would recommend fixing the spacing and downloading, and then start logging and see what you can tell from that (is all the data being sent? the responses? Is tehre a place where it stops? etc.)

If you need help, please post the log so I can take a look.

Thanks!

Kyle


#10

Ah ha I see! Thank you for the clarification. Looks like my configuration will be changing again. Appreciate all your assistance


#11

Kyle,

Can you take a look at this one and let me know if you think this configuration will work. I just loaded it to the Anybus. I think this will get us to where we need to be. do their have to be commands listed in this sub network tree to trigger a response, or is that all initiated by the PLC controller? I still have a subnet RED light on the Anybus, Once we have plc in run, will that rectify the subnet issue?

Anybus CFG 07-30-19.cfg (16 KB)


#12

Kyle,

Can you take a look at this log file and let me know how this reads please? Thank you for the assistance sir!

log 03-08-19.txt (36.7 KB)


#13

Hello,

Kyle is on vacation today and I am helping out with his support cases. Looking at the configuration it good for the most part. One thing that catches my eye is that the registers are a bit high being 0x1FE0 puts it in dec 8028. This isn’t necessarily wrong but I do not see this often and you might want to check this with the nodes modbus register map.

Looking at the serial LOG it looks like the communicator is working correctly but since we only see Tx or transmit data we are not getting any Rx date or messages back from the Nodes. This type of issue is typically associated with an issue on bottom three layers of the communication protocol. The wiring, the serial configuration or the itself is not correct.

I would recommend you start by making sure the Wiring is correct if it is you will then want to make sure the Serial settings the communicator is using matches the settings on compressors. Since we can see that me messages being sent in the log we can determin that they are formatted correctly. What we can not verify is what Node id the devices are using, you might want to make sure you are setting the correct node ID’s for the devices.

Deryck


#14

Deryck,

Thank you for the reply. We are going to go back through all the end devices to make sure our node addressing is correct. Upon verification of that, I’ll run another log file and send over to you. I greatly appreciate the information.


#15

If you would like to check your self you can see if there is data in the RX columns of the log. If there is no data still you are still having an issue as described above.

Deryck


#16

Deryck,

I believe we have major wiring issues as they originally wired these points up in a star configuration. I think I received data back from our node 3 which I have configured for 6 registers to be polled. I wired directly to it to troubleshoot the issues. Do you have time for a call?

log 08-05-19.txt (36.5 KB)

LOG 08-05-19 W_RESISTOR.txt (34.5 KB)


#17

Hello,

Looking at the logs the log labeled W_RESISTOR we can see the transactions to node 3 going though successfully. The other log seems to have mostly garbled data. If the serial settings are not being changed this does look like a wiring issue. Where we are seeing a lot of garbled data on the TX line perhaps the Rx and Tx lines are not wired as expected.

I should be available all week if you would like to call into the support line 312-829-0601 and select the options for support and anybus. If you don’t make it to me directly you can ask to be transferred.

Regards,
Deryck


#18

Hi Jeremy,

I just tried giving you a call but it looks like your mailbox was full


#19

Call back when you can. I just tried calling. Spoke with Kevin


#20

Deryck,

Thank you for the reply. Here is another log of where I am getting more RX back. How exactly do you read this log? from what I can cypher is I have all 5 on x01 response, 2 of 3 on x02 response, 0 of 6 on x03, 2 of 2 on x04 response 2 of 2 on x05 response, 0 of 2 on x06 and x07 2 of 2 transmissions.

LOG 08-06-19.txt (32.8 KB)


#21

Hi Jeremy, just tried again but it went to voicemail