AB7000-C Communicator - ACM Connect/Download Issues

I have two new AB7000-C devices and downloaded the most recent version of ACM ( to configure them. I am unable to connect to one of the devices. I can connect to the second device, but the download always fails with the message “Could not download to Communicator”. I have tried a factory reset using ACM, but it appears to fail as well. I have tried several different USB-serial converters with no change. I also tried another PC with the same results. I confirmed that the USB-serial converters work with other devices.

The LEDs on the communicators are as follows:
1 - OFF, 2 - RED, 3 - OFF, 4 - OFF, 5 - RED, 6 - RED/GREEN alternating

I believe this means that it has no configuration, which I would expect because they are new out of the box.

Should I try a factory restore or is there something else I can try?

Hi @dgivens,

Have you tried the Factory Restore option under Tools > Options… > Module ?

Or the Factory Reset (see pdf):

I would recommend trying both. First the Reset (shorting the jumper), then the Factory Restore in the ACM Tools menu.

Also, can you please provide the serial number for the device in question?

Thank you,


Hi Kyle,

I want to point out that I have two identical devices. One of them will connect with ACM but downloads fail, the other will not even connect.

I have tried the reset (shorting the jumper) and then the Factory Restore in the ACM Tools menu on both devices. The results are the same. I can connect to one device but a download fails, and I still cannot connect to the second device to perform the Factory Restore in ACM.

The serial numbers are 0002FE2B (connects but download fails) and 0002FE2E (will not connect).

Sorry, I misread your first post. Are you using the included RJ11 to DB9 cable to connect to the programming port (RJ11) to download the configuration?

Yes, I am using the included cable (RJ11 to DB9) cable to connect to the devices. I’ve confirmed that my USB-serial converter is working properly by connecting to a completely different device. I also had a coworker try to connect/download to one of these devices using his PC, which he used to successfully configure a different model Communicator (AB7007) recently. He experienced the same issues with these devices. I feel like I’ve ruled out any issues with my PC, cables, etc.

Do you have just the one programming cable or do you have 2? It’s very unusual that both devices would be defective, so I want to make sure to do due diligence.

I thought the same thing. I have two cables, and I tried both with the same results. There are more cables at my office along with several AB7007 devices. I may try connecting to one of the AB7007 Communicators to confirm that the issue is with the new AB7000 devices and not my PC, cable, etc. I’ll let you know the results.

That would be great, thank you.

I got one of the AB7007 devices from my office. I used the same cables as before and was able to download a configuration without any issue. It’s very surprising, but I think I’ve determined that I have two defective AB7000 devices. I can only connect to one of them, and I still have not been able to successfully download to it.

Let me know what I can do to get two new AB7000 devices ASAP.

That’s a shame. I’ll open a case to start the RMA process, you’ll need to provide the case number to your distributor for the replacements. You’ll receive an email from me in a few minutes.

It’s unfortunate, but it happens. I’ve already sent the information to my distributor to see about getting replacement units. Thank you for your help.

Absolutely, and I apologize for your inconvenience. Let me know if you have any other questions.

A post was split to a new topic: AB7000 connection issues