AB7607 word sizing issues

So at work I’ve recently had to replace an HMS AB7607 ethernet/devicenet gateway on one of our older networks. The older device was a AB7607-B ( rev1.8 ) and the new device was a AB7607-C (rev 2.4), the new device accepted the old config through RSNetworx for devicenet without any issues. But what i found is that I was now getting code16#0109 Connection Request error: Invalid Connection Size on the gateway in my IO tree in rslogix. None of the mapping in the gateway has changed the only way i could get it to connect and get the fault to clear was increase the input and output sizing to maximum (as seen in the attached pics). This then created the issue of intermittent comms dropouts on the scanner so i had to issue increase the RPI from 50ms to 100ms. which i shouldn’t have to do as the network is fairly small with only 5 nodes made up of 3 encoders and 2 IO modules. The network is now running but occasionally all three encoders will flat line this has only begun to happen since the change out, i’ve checked the network with a scope and the signal looks fine and i’ve checked all device taps, powertaps and end of line resistors which are all fine. The only thing i can think of which would cause this issue is me maxing out the input/output word sizing and the increase in the RPI.

So my question is how can i reduce the word sizing back to only grab the data i require as when i change the values from anything lower than the max size input output I run into the word sizing fault again. I’ve ensured that everything is matching up ie SINTS are being used in the scanner and PLC so there’s no mismatches. Ive gone over the manual and i can see anything why i would event need to increase the word sizing after the upgrade. Is anyone able to help?

5e6364142707c_NewConfig.png.604fd1ad05673cef2680050fef6df2bf 5e6364159e81d_OldConfig.png.b31be582897132e1c6e89b6a4b3517e5

Are you using the BW Config software to set the I/O sizes on the X-Gateway?

You can set the size to whatever you require:

Also see Section 6-3 of User Manual.

Valid size range and connection points:

Hey Kyle, Connection size was already set at 500 bytes. Tried conditioning the I/O size to the specific I/O size required in PLC but alas still no luck.

Point of concern is that we can utilise a old REV 1.8 (AB7607) from another piece of equipment, re-configure the IP configuration to suit, perform a download and place back into run mode and we encounter no issues.

What happens when you set it to match the IO size in the PLC? Any error? Can you share a screenshot of that?

Do you know if a Control/Status word is used?

4-22-2021 6-07-39 AM

Status word as seen above and same module fault code present, verified bus voltage is stable @ 24V and have verified the end device “absolute encoder” has no faults or issues when used with previous version of AB7607.

Interestingly when you upload the configuration from a field device on windows 10 the I/O size configuration parameter isn’t visible the only way we could get it to display was by using an old windows XP Toughbook we had still available.

The problem here, as the fault indicates in Studio, is that the connection size that the gateway is trying to use is invalid. This seems to be related to the Status word. The Status word is only 4 bytes. I noticed you have 128 bytes in the config. (Maybe you have confused with bits?)


Make sure that after you update the I/O size on either the PLC or the gateway, you download the changes.

I am using Windows 10 myself and am not experiencing this issue with the I/O size missing. Have you tried changing from Run to Idle mode?