AB7702 RS485

I am using a AB7702 as an interface from a Modbus TCP/IP Master (PC) to a Modem Modbus RS485 acting as a slave.

We can communicate with the Modem from a PC Serial Modbus Modbus using Calta MDBus (see below), but we had to increase RTS/TX Delay to 1, and RTS Extra to 10 to connect to the Modem.


I have tried all possibilities of timer settings within the AB7702 serial settings, also reversing the two RS485 wires, but no success with communicating to the Modem via the AB7702. I believe the issue maybe related to RTS/CTS.

Do you have any suggestions what I could try to solve this issue?

Can you tell me what the LEDs on the device are doing?


Can you check and make sure that the pinout for your serial cable is matching what the device is using?

Another thing you could try would be to download something like the Modbus CAS Scanner below:
Modbus CAS Scanner

Then you can try and read from the serial side using a USB to serial adapter on your computer or if your computer has a serial port on the front that would work as well.

Status - Solid Green
Serial Link - Flashes Red slowly, ON for small time, OFF for long time
Activity - Flashes Green - ON for long time, OFF for short time
Link Solid Orange

The 2 wire RS485 is connected to 13 & 14, I have swapping these, also tried connecting 15 common but no change.

We tried doing what you suggest with Modbus CAS scanner using Calta MDBus on Monitor mode, but I will try Modbus CAS Scanner as you suggest and let you know results.

Hi @vincent.massingham ,

Let me know what you find out on that serial side once you get the CAS scanner up and running


HI Tim

Before I try the Modbus CAS Scanner, please find below screen dump using Calta MDBus. LHS is Modbus TCP Master, LHS is Modbus Serial RS485 Monitor only.

You can see on the RHS Monitor display the MB TCP MSG has been converted to RS485 and monitored ok with good CRC, matches what LHS has transmitted. But the Modem Modbus Slave is not responding?

I can monitor RS485 MSGs received at the Modem, see screen dump below, the UART3 Fail increments for every Modbus MSG from the AB7702?

It looks like our device is responding with this error message:

Hi @vincent.massingham ,

Were you able to find out why your device wasn’t responding?