AB7808 Gateway

Dear Experts,
I have three old type of AB7808 Gateways installed with three PLCs, one of them Sn#A01DB725 is giving only 1st 10 Holding registers on data read. I am suspecting its configuration file may be different. I need to connect to this gateway. How i can connect to read parameters for MODBUS. I tried to connect using “Anybus Configuration Manager V1.5.1.1” but it says timeout. I read one thread in forum that somone connected using HyperTerminal, i have tried with that method its showing connected but when i come to configuration manager it say module in use. Can anyone explain the correct method to connect with these gateways. I have uploaded snaps of the Gateway and Modscan.
Thanks and Best Regards,Boiler3 10HR


Here is a link to our legacy support files. One of the zip files includes Hyperterminal and possibly more useful for you instructions. if you are getting a error saying it is in use I suspect you are not making the connection correctly.

Are you connecting to the Config port? Are you restarting the gateway?

You should be able to connect over ACM as well. Are you selecting the correct comport? Can you try restarting the gatway right before you try connecting?


Hi thanks for reply, i wasn’t restarting after Hyper Terminal connection. I should do it and share my experience. Now what i understood is:
1- we need to connect with hyper terminal
2-Restart the gateway
3-Open ACM, select the same com port where the gateway is connected
4-Upload configuration

Great! Glad to hear you were able to connect.

Hi Deryck,

I just consolidated steps above but so far didn’t had a chance to try. Once I shall connect successfully, I will make a video and share in forum to help others.


Hi Deryck,

I have tried to connect with the Gateway using Hyper terminal and restarted the gateway but it didn’t replied any response. I have also tried to connect using ACM but didn’t worked. I am using serial to USB converter and i am using a null modem cable. I have tried the cable straight and cross both connections but it didn’t worked. Please help me.


Are you saying with and without the null modem here?

I guess i did not read these instructions closely. You can use either Hyperterminal or ACM. You do not connect with hyperterminal then connect with ACM.

Have you followed the instructions included with the Hyperterminal zip?
Readme.pdf (297.7 KB)

You will need to open up hyperterminal and setup a new “modem” This will be configuring the COM port connected to the X-gateway with the following:
Bits per second: 57600
Data bits: 8
Parity: None
Stop bits: 1
Flow control: None


In hyperterminal you should then be able to “call”. with the call open you would restart the x-gateway.

Dear Deryck,
Thanks a lot it worked and i was able to upload and download configuration file. The issue was null modem cable I was using ready made with all 9 pins connected. I removed all and connected 2 and 3 in cross and 5 in straight. I tried separately with Hyper terminal, it woks as well.

I can summarize it in three steps:

1-Use the cable as per manual (schematic attached)
2-Select the right serial port (Serial to USB converter cab be used) in ACM software or Hyper Terminal
3-Upload the parameters.

Video Link attached for more details:
HMS ANYBUS X Gateway ModBUs Configuration - YouTube

@Shabbir_Ahmad ,

Thanks for following up and adding some details. Glad to see you got this working with ACM.


1 Like