AB7817 No Modbus RTU Comm

DeviceNet network configuration was easy. Unable to get RTU to communicate. We have a 4 wire RS485. I have to use a RS422 - RS232 adapter to allow the handshaking and keep our DCS system (Emerson Ovation) from reporting ‘Comm Failure’. Anybus is configured as RS232 and RTU address 1.

I’ve tried different I/O register sizes to get some response. Address overview looks incomplete. Set operation mode screen has ‘Unavailable’.

Seems the Anybus gateway isn’t recognizing the Modbus address poll from Allen-Bradley E3 overloads. Our DCS is requesting device status (word), and phase current (3 integers).


What serial standard is being used just between the master and the slave? Why are you using a RS422 to RS232 converter?

What is the modbus RTU master? Are you seeing any modbus response back?

Network Interface Addendum, Anybus-X Modbus RTU Slave Interface (hms-networks.com)


To interface a 4 wire RS485 to your 2 wire connector, I used a RS422/RS232 adapter. I tried changing other wiring, but our DCS faults with a ‘Datalink failure’. I see polling from DCS. This polls 4 AB E3 overloads, requesting status and phase currents (1 word, 3 int). Command from DCS is 3 bits, triggering OUTA, OUTB or Reset.

Let me know if you have wiring method I should try. I’ll see if I can bridge the RS485 send/receive pairs to a 2 wire. There are other links with this setup.


We only support RS485 2 wire or rs232 with this device.

This doesn’t really have enough context for me to understand this. What I would be interested in would be, what modbus requests are being used to query the AB7817 modbus slave interface?
Are you seeing any modbus responses back?