Add On Profile Crashing Studio 5000 Logix Desgner

Hi,

I am trying to set up a HMS-EN2PB-R with a ControlLogix. Every time I try to launch the configuration manager for the HMS-EN2PB-R, Studio 5000 posts an error then crashes. I installed the latest version of the AOP from our web site (v1.02.11). I am running Studio 5000 on a Virtual Machine with Windows 7. I do not have any issues with the Serial or Modbus-TCP linking devices…only the Profibus linking device.

Studio 5000 Logix Designer Version…
image

Module Properties…

Click on “Change”…

Click on “View and edit the network”…then fatal error.

Is this a known issue? Please let me know what troubleshooting steps to take.

Thanks!

We have not encountered this exact issue, however I would suggest uninstalling and reinstalling the AOP. This is how you can reinstall it,

  1. Navigate to this directory “C:\Program Files (x86)\Rockwell Software\RSLogix 5000\Module Profiles\Install”

  2. Hit Shift + right click and select “open command window here”

image

  1. In the command prompt type “MPSETUP/CU”

  1. A dialogue window will appear, hit next and then select “Uninstall” and select next again.

  2. From here find the “HMS Ethernet_IP Linking Device” option. PLEASE NOTE: be careful not to unintentionally uninstall any other Rockwell profiles.

image

  1. Select Next again and then finally uninstall

  2. After the uninstall is complete please go to the following link to download and install the latest AOP software.

https://www.anybus.com/docs/librariesprovider7/default-document-library/firmware-software/hms-aop-en2xx-r.zip?sfvrsn=bedabfd6_20

Hi Nick,

I followed your procedure to uninstall and re-install the AOPs. Unfortunately, I am still getting the same error after doing this. The error is repeatable and it does not occur with either of the Modbus-TCP or Serial Linking Devices. Also, I tried this with RSLogix 5000 (also installed on my VM) and I get the same error and crash.

Any other ideas about what I can try next?

Thanks!
Trevor

Have you ever been able to launch the configuration interface? Or has it given this message from the very beginning?

You are plugged into the X1 ports on the front, correct?

I have never been able to launch the configuration interface. This has occurred since my first attempt.

Yep plugged into X1.1. Also tried X1.2.

Ethernet port on VM is set 192.168.150.12
Ethernet port on Host PC is 192.168.150.13
ControlLogix Ethernet is 192.168.150.100
Linking Device is at 192.168.150.171
(all fixed IP addresses)

I can ping both the ControlLogix and the Linking Device from the VM and from the Host.

I have informed a support colleague in Sweden of this behavior. I am going to update him and ask him his thoughts.

Hi Trevor,

Have you tried launching the AOP while disconnected from the Gateway? Does it give you the same error?

Hello,

This did turn out to be a known issue, Trevor found the following.

"The IP address for my Linking Device was 192.168.150.171. I tried changing it to something completely different (10.10.0.99) and it die NOT crash. I tried 192.168.150.170 and it crashed. I tried 192.168.150.66 and it did NOT crash! I tried several 2-digit values for the fourth octet and no crashing. However, I tried several 3-digit numbers in the last octet and it crashes. "

This is a bug relating to the last octet of the IP address, this issue is being addressed by development.

Hi Guys Has this issue been resolved yet

Hello,

Yes, this will have been addressed in the new versions being released.

Nick