Anybus HMS-EN2PB-R Fatal errors


#1

Hello,

A client is having problems with the first configuration of a HMS-EN2PB-R gateway. He used the BOOTP-DHCP Tool to set the IP address, installed the EDS files and configured it on Studio 5000 Logix Designer.

When he downloaded the configuration to the PLC and the Gateway, the MS EN and NS’s LEDs were Stedy in Red (Fatal Error according to the user manual). The connections of the 2 ethernet ports were disabled and he couldn’t get any signal from the ports (it seems like both ports are disconnected).

Then he tried to connect over USB port, but the driver wasn’t found. I think the problem will be solved by making a Factory Reset on the module, but there’s no way to do it physically (there’s no reset button), only by Software.

Is there anything to recover this Gateway or any way to make the factory reset on this module?

We’ve tried to use the IPConfig tool but the network status is null.

I’m sending photos of the Gateway attached to this e-mail

Thanks and Best Regards!

Chanlucas Hsieh

CapeCaneDOS:Users:kerrikorth:Desktop:CEEmailGraphic.jpg


#2

#6

Can you try looking over this document found the software section of the link below and see if you can get it working that way?

https://www.anybus.com/support/file-doc-downloads/linking-devices-specific/?ordercode=HMS-EN2PB-R


#8

Hi Tim!

Thanks for your answer!

We’ve already used all resources from this page, including manuals and IPConfig Software.

Is there any driver to use for the USB port or any other way to make the factory reset manually?


#9

Hey Chanlucas

Sorry but I’m thinking this device may not be recoverable. Do you know if you purchased the device in the last 24 months?


#10

Yes it was purchased last month.

We succeeded in communicating the gateway to the PC’s Ethernet port. But some GSV files from SMAR are not functioning well. Is it a new case? Have you ever had any troubleshooting with it?

Chanlucas Hsieh


#11

Hello,

Unfortunately if it’s getting fatal error responses and not being responsive, we may need to do an RMA for this device


#12

#13

Hi Tim!

I think that it’s a problem of configuration, please see the error in the attached image.

We are trying to make the communication using the GSD file from SMAR.

Att,

Chanlucas Hsieh

Certificada TRACE

Certificada GPTW

CapeCaneDOS:Users:kerrikorth:Desktop:CEEmailGraphic.jpg


#14

Hi @Chanlucas

Was this with the original device or a new one?


#15

Hi Tim!

The both equipments had the same error

Att,

Chanlucas Hsieh

Engenharia de Produtos – Automação, Softwares e Redes

Celular: +55 |31| 99678-1894


#16

#17

Hi @Chanlucas

Do you know if both of these devices have been updated to the most recent firmware?


#18

Hi Tim!

The modules are in the latest firmware version.

The problem is related to these GSD files attached, please take a look.

I don’t think that the problem is related to the module itself, but some memory assembling using the GSD files from SMAR.

Att,

YP00089A.GSD (6.04 KB)

YP000895.GSD (6.34 KB)

YP000897.GSD (7.01 KB)


#19

I’m going to try and escalate this issue to our colleagues over in Belgium to get somebody with more experience on this one


#20

Thanks Tim!

I’ll be waiting for News.

Att,



#21

#22

Hello @Chanlucas,

Can you provide a copy of the .ACD project for us to take a look at.

Deryck


#23

Hi Deryck!

Please see the .ACD file attached.

Att,

UVG_Caldeira3_Rev20_BB.ACD (3.01 MB)


#24

Thank you,

I have sent this to the developers looking into this issue.

Deryck