Anybus HMS-EN2SE-R cannot communicate with serial network

Not familiar with setting up serial networks and kinda hitting a wall with configuration for subject module. Using Rev 32.12 L81E, and Rev 4.7 EN2SE-R

I have the module set up in my I/O configuration, LED 1 and 2 solid green, confirming comms with PLC. LED 3 unlit. LED 4 green flashing for E/IP comm traffic. LED 5 solid red. LED 6 flashing green.

When laptop is connected to L81E processor and EN2SE-R is connected to EN2TR, cannot establish communications with Anybus module from laptop. When connected to EN2TR along with module, communications easily established. On Configuration Manager, the Config Valid and Config Line LEDs are green, but Checksum Valid is red.

4-wire RS485 serial network, DB9 connector with pins 6/7 are Rx, pins 8/9 are Tx according the drawings I was given, so that’s how I wired it. I was told 4800, n, 8, 1 for communications setup. Trying to set up with Generic Data Mode. The Process Tags coming from the PLC should be 2 bytes, byte 0 is the address one of the serial devices, and byte 1 is the value 64. The serial devices send back 11 bytes each. See attached configuration files. I’m guessing there is something very simple that my lack of familiarity with serial networks is causing me most of my headaches.

Generic.cfg (16.0 KB) Generic.cfx (6.1 KB)

Are you able to use TeamViewer on your laptop? TeamViewer download

If so could I try and take a look at this setup with you when you have some free time?

Yes, I have TeamViewer. We use it for our own customer support. I am available most of the day.

Apart from a meeting at 10AM eastern time this morning, I’m free. What is a good time for you?

I can do anything. I just started my day. Aside from lunch around 12 PST, I anticipate being around my desk all day.

Does 1PM PST (4PM EST) work for you?

That will work perfectly. Thank you.

Hey Jack,

Let me know what you find out for the wiring of that device and get values coming into the logging section.


Still nothing but zeroes in the logging. I’ll try to find something on the device and see if I can find a manual. I believe we order the PCBs as they are and we just install them. I’m also gonna try looking at it with a terminal program to see if I can at least sort out the communications aspects.

Ok let me know if you’re able to get any data using something like terminal or putty

That was actually one of the first things I tried today. I connected to the same points (parallel connection) and started up Putty. I can get data if I create a Produce with a constant byte. Well… it did the first time, but doesn’t seem to be doing that now…

I see my receiving light on my USB/Serial interface light up, but nothing shows up in the terminal unless I have a constant byte. Still nothing in the Rx section of the log. I have no clue why I’m not getting anything from the PLC when all the lights say everything is great…

Were you able to get a manual for that device to see if there’s a more consistent way to trigger data to send?

I was not. There is no start/end character.

Everything I’ve been given is “It’s just simple serial communications RS485 4-wire”

At this time, the project is dead in the water and low priority as we have a serial workaround. It may be picked back up when projects slow down.

Ok, I’ll mark this solved for now until you have time to work on it again. but let me know if you’re able to find more information on this device and get it to consistently print messages in something like putty