Anybus Wireless Bolt - WPA2 Incompatibility - Ethernet Port Goes Down


I’ve had some troubles with a setup with a ProSoft RLX2-IHNF-A as the access point and Anybus AWB2030-B as a client.

A problem free connection is possible with no authentication enabled. Selecting WPA/WPA2-PSK authentication on the Anybus and WPA/WPA2 Personal on the ProSoft and my PC connection to the Anybus via the Ethernet port drops out! I watch the PC port status (Network Connections in Windows 10 PC) and it is going from connected to “Network cable unplugged”. I turn power off to the ProSoft (so there is no access point for the Anybus to connect to) and the Ethernet connection returns.

I change the security mode on the ProSoft from WPA/WPA2 Personal to just WPA Personal and there is no problems. The problem is with just WPA2.

We could say the problem is with the ProSoft implementation of WPA2 not the Anybus, but because the Ethernet port becomes dysfunctional - it should not die because of the WLAN - I’ve come here first to report it as a bug. Hopefully, at the same whatever the WPA2 incompatibility issue is between the two devices can be resolved at the same time.


Hello Lewis,

This is a bit of an odd issue we have not see any other issues with WPA/WPA2 causing issues on the bolt. Can you provide more details regarding when this issue happens? Does this happen when the Bolt connects to the ProSoft AP or just when the AP is on? For example if it is paired to another AP and then you turn on the ProSoft AP does the connection drop?

What are the LED’s on the RJ45 jack doing, both before it connects then after it connects? How is it flashing and what color is it?


Hi Deryck

It happens only when the Bolt actually connects to the ProSoft AP. For instance, if everything is set up but I put the wrong Passkey in the Bolt, there is no issue.

Before the Bolt connects to the ProSoft AP, LED A is flashing yellow and LED B is constant purple. After the AP is switched on the Bolt cycles through the following 4 states:

  1. LED A flashing yellow and LED B constant purple. ~3 secs.
  2. LED A off and LED B off. ~1 sec.
  3. LED A off and LED B constant purple. ~3 secs.
  4. LED A off and LED B flashing red. ~1 sec.


Hi Lewis,

the light pattern you describe sounds consistent with the device not being configured for the AP but not connected to anything on the LAN. Does it match the following video?

For this video I had the bolt connected with a POE injector but did not connect the LAN into anything so the LAN was disconnected.

Is the PC also connected to the Prosoft network?

Hi Deryck

Was this looked at?


Sorry about that lewis. The above post was typed up immediately but not posted it was sitting as a pending post when I checked.

No worries Deryck.
It doesn’t match the above video. I’ve attached links to 4 videos for different conditions below.
The laptop the Bolt is connected to by Ethernet doesn’t have it’s Wi-Fi connected to the same WLAN. Although it can be (tested this).

No Ethernet cable connected and ProSoft AP Off:

No Ethernet cable connected and ProSoft AP On:

Ethernet cable connected and ProSoft AP Off:

Ethernet cable connected and ProSoft AP On:

Hi Lewis,

Thank you for all the videos. I’m can’t tell exactly what state the bolt is going into when connecting to the AP with the Ethernet connected. It looks like the device is trying to connect, possibly connects, then it might be rebooting. I am going to check with my colleagues in Sweden to see if they know what state the device is going into.

Can look at what encryption the AP is using?

If you have not already update the bolt to the latest Firmware.

PS It looks like Drive doen’t play nice with the forum. I fixed them the best I can for now but two of them need to be opened externally. We have a pending forum update that should fix this.

Doing a little more research I found a case where Prosoft had to update the firmware of their AP to correct an issue. Check and see if there is a update available for the AP you are using. In that case they were using an (ProSoft modelRLX2-IHNF-WC Industrial AP) . The devices were connecting in that case but would periodically drop off line.


Hi Deryck. Thanks for fixing up the videos. Yeah two of them were too large for just normal upload to the forum.

Agree it does look like it’s connected and then reboots. Each cycle the connection in Windows changes to “Network cable unplugged” also suggests it turns off for a moment.

I said in my original post the problem is related to WPA2 encryption because it works fine with WPA.

I’ve now updated the Bolt to the latest firmware, 2.0.12, and the RLX2 to the latest, v0037G, but no fix.

Hi Lewis,

Can you provide a backup of the Bolt? I would like to review.
There should be two encryption option on the AP. WPA2, AES and TKIP. Does changing it from one to the other have any effect on the bolt.


Here is the backup.
backup.dat (2.5 KB)

The encryption options for Security Mode “WPA/WPA2 Personal” on the AP are “AES & TKIP” or “AES”. Changing the Encryption setting doesn’t change anything for the Bolt.


The only option that works is using Security Mode “WPA Personal”, i.e., disabling the use of WPA2. We don’t use Enterprise mode.


Hi Lewis,

To try and get more info on the state of the bolt can you setup a syslogger on your PC such as On the AWB we can run the follow AT commands to have it send out log event. This might give us more info about on why it is rebooting.

AT*AMESS=,,514,4,1 you will need to update this to have your PCs IP address. Port 514 is the standard syslog port.


I’ve sent the AT commands as you described but am not receiving any syslog messages from the Bolt. I don’t believe it’s the syslog server (Kiwi Syslog) setup because I’m not seeing any UDP port 514 traffic in Wireshark.


Hi Lewis,

Those settings looks correct, I will try and setup a bolt to verify I can still get the logs with them.

To get some info on the Bolts state when it tries to connect to the AP run AT*AMDUMP? from the AT window this will show the up time and the number of reboots. I would like to see if when connecting to the AP it triggers the bolt to reboot.

Looking over your config again. I did see you have Bluetooth enabled. Can you disable it? We had issues previously where running both BT and WLAN at the same time caused issues.

Also, did you ever try setting the encryption to AES only?

Hi Deryck

Yes the Bolt is rebooting from the AT*AMDUMP. Before turning on the AP:

Not long after the AP powers up:

Disabling Bluetooth has no effect.

We discussed encryption settings, including AES only, just a couple of posts up:

“The encryption options for Security Mode “WPA/WPA2 Personal” on the AP are “AES & TKIP” or “AES”. Changing the Encryption setting doesn’t change anything for the Bolt.”

“The only option that works is using Security Mode “WPA Personal”, i.e., disabling the use of WPA2. We don’t use Enterprise mode.”


Hi Lewis,

I apologize for the delay, I am seeing if the development team has any input on this issue. We have not seen any other issues like this so we are not sure if it could be the bolt or the Prosoft causing the issues. I hope to hear back from them soon with more info.

Have you checked with Prosoft to see if they have reports of the RLX2-IHNF-A causing similar issues with other device.


I tried these command (with my IP of course) using the Bolt’s web interface, but when trying to set the syslog ip address it fails.