Anybus x-gateway AB7800-F Led GW status red

Hi, I’m Gabriel.

I need your support on download the firmware to anybus x-gateway (ProfibusDP Master - Ethernet IP/Adapter Slave).

I was follow the manual (Anybus Firmware Download TP) then I was configured the next information.

1.- Connect the module.
2.- Choose Interface (In my case Anybus X-Gateway)
3.- Control Page (Choose firmware)
4.- Settings ( Select Target: Carrierboard)
5.- Transport Paths (COM-Port Transport Provider) (COM 3)
6.- Load ( I was select FWP_ABX_1508_V_3_19_01.fwp)
7.- Start.

Before loading this file all indicators were in status ok, then I loaded this file FWP_ABX_1508_V_3_19 I turned Off and turned On.

When I turned On the indicator ‘‘GW Status’’ was in red (static) and the other’s indicators were Off.

Where did you get the firmware?

What is the serial number of the Anybus?

Hi kyle, thanks for replying.

I got it in one of the folders I downloaded, but apparently I think it’s from anybus classic.

Serial number of the Anybus.

Then I downloaded a fwp file in a hms forum (FWP_ABX_V_3_29_01_D.FWP), but it didn’t work for me. I got an error.

What is the error? Can you take a screenshot?

That looks like the correct firmware. I’ll post it here again so you can be sure it’s correct. However, you may have bricked the gateway when you downloaded the wrong firmware. It’s also possible that it could be just a connection issue. Does the download finish? If not, have you tried power cycling the gateway after connecting, but before downloading?

Please follow these instructions:
Firmware upgrade

  1. Connect the Anybus X-gateway with an USB cable.
  2. Start “Firmware download TP” program
  3. Follow the instructions in the “Instruction” window to upgrade the software. When the question of target comes choose “Carrierboard”. When the question of version comes up please choose the expected target hardware and software to be downloaded. The file that should be downloaded is the fwp file (Firmware Package) file.
  4. A power cycle is required after the application has downloaded and the gateway self reboots.
  5. If the download is successful a window indicating “Transfer OK” will be displayed (72.9 KB)

The download doesn’t finish, and I tried power cycling the gateway after connecting but I got the same error.

Also try to did it by Hyperteminal, I got the option ‘’ Download a new firmware ‘’, but it seems to me it remains cycled.

I would recommend you keep trying with FW Download TP. It seems like it’s still communicating, so keep trying and eventually I think it will accept the download.