Anybus X-Gayeway AB7808 Timeout Reading Configuration Using Configuration Manager

We are trying to use the AB7808 to read data from a PROFIBUS slave device from a Modbus master.

As I under stand it, the PROFIBUS side (X1) of the device functions as a PROFIBUS master and allows data to be read from PROFIBUS slave devices from the Modbus side (X2).

So, I configured all the dip switches according to the manual to match my port settings but I am not getting any readings at all from the Modbus (X2) side.

I installed the Anybus Configuration Manager - X -gateway software and hooked up my computer (Windows 10 Pro) via the USB cable (X4) interface. That connection shows up in my device manager as HMS Industrial Networks Anybus X-gateway

In the configuration I choose “Select connection” and pick the COM8 (which it sees and actually shows the serial number of my device). Then I choose “Connect” and it seems to connect fine (no errors). But, if I try to upload or download the configuration, I get a message “Timeout when communicating with the module!”.

I have also tried downloading and installing the latest transport provider drivers and I have even tried using the PROFIBUS (X1.2) port with the serial cable that came with the device. Everything I try ends up with “Timeout when communicating with the module!”



You should definitely be using the USB port with the configuration manager.

Can you go to programs and features in the control panel and take a look at what is installed for HMS software? Sometimes if you have the transport providers installed twice you will get conflicts that cause errors like this. In programs and features you will see the transport providers twice if you have redundant installations. If this is the case please uninstall the oldest version.

Best regards,


I just looked…There is only one version. Version #

Also, just to try something different, I installed the configuration manager on a different machine. And, I’m seeing the same issue…It sees the USB connection (with serial number), but when I try to do anything, I get the timeout message.

Ok, I think the next step will be to connect with hyperterminal and try and set the configuration this way. When you connect and apply a configuration this way it usually will fix this issue.

The following folder contains hyperterminal and a readme for connecting to the gateway with hyperterminal.

In “C:…\Legacy X-gateway(ABxxxx-B-C) files\Legacy X-gateway(ABxxxx-B-C) files\Legacy X-gateway - configuration files - programs - applications - drawings - certifications” you will find these. When you connect to the gateway with hyperterminal you may need to power cycle the gateway for the config menu to appear. From there you can select option 6 to apply a configuration. After doing this you should be able to connect and download with the configuration manager.

Where am I getting this from? I looked in my files and I can’t find it. Also, I connect with hyperterminal, but then what do I do…The README only tells me how to connect.

There are a lot of zipped files in that download link, I’m guessing I only use “X-gateway and HyperTerminal”

Actually…It worked…Now I’m able to connect using the configuration manager…No more timeouts :slight_smile:

Thanks again for the awesome help Nick!

I am glad that worked, thanks for the update!


Hi!, I’m having the same issue but I can’t find the file to send to the gateway (C:…\Legacy X-gateway(ABxxxx-B-C) files\Legacy X-gateway(ABxxxx-B-C) files\Legacy X-gateway - configuration files - programs - applications - drawings - certifications
Where can I find it?


The zip file is available in the following link.

A post was split to a new topic: Legacy device not communicating for config


How did it work?
Am still having the same problems

@hagenimana how did what work? Are you having problems connecting to your gateway? What is the article number for your device? What connection are you using and what software are you using?

the same issue with AB7306.

For me, the hyperterminal solution did not work. Im using windows 7.

Hello guys,

Check in device manager that you see the gateway listed as a USB device.

Then in ACM double check what com port is used for the connection. go to tools > select connection and click the config button. image

I don’t know if this helps anyone, but I had this problem with two Anybus-X GW, EtherCAT to Modbus RTU. I could not connect to either with the ACM and I tried from two different machines. I used Hyperterminal to connect but nothing is displayed until you power-cycle the GW, then the terminal shows some boot up info and you can get to a menu with 9 or so options. You don’t need to do anything more with Hyperterminal, whatever the comm glitch is it appears to be reset simply by booting up with a terminal connected. ACM worked right away after this, on both GWs we have in our system.

This helped a lot. When I connected with the HyperTerminal, I downloaded a configuration to my gateway and then tried connecting via the Anybus Configuration Manager. This didn’t work.

When I tried doing what you suggested, only making a connection to the HyperTerminal (after power cycling the Gateway), the configuration manager is now working.