Anybus Xgateway DeviceNet to ModbusTCP


#1

Hello,

I have a couple of DeviceNet networks where I can discover and build my Modbus directory using the Anybus Xgateway.

The issue I have is communicating with any of the Modbus registers greater than 10 on both the Rx and Tx. Communication seems to be working as long as I poll only the fist 10 addresses but when I try to poll 11 or more I lose communication to all registers. I tested this with a Modbus scanner as well with the same result.

Is there a setting in the gateway that is limiting the total addresses I can poll? I have built gaps with known mac addresses that can be on the network but these missing mac addresses can be within the first ten Modbus registers without issues.

Thank you,

David


#2

Hi @David_RBT,

Which gateway are you using? Is it the AB7635 or a different one?

What software are you using to configure the DeviceNET network?

Just the fact that it’s up to 10 makes me wonder if this is an issue between translating Hex to Decimal.

Kyle


#4

Hi @kyle_HMS,

I am using the AB7630. The configuration software is the Anybus Configuration Manager, version 3.6.1.1.

image

I am using the gateway to talk to a Niagara JACE. The Modbus driver allows me to use Hex, Decimal or Modbus. Each register is a 16 bit string while on the gateway each device is only 8 bits each so there are two devices per register.

Thanks,
David


#5

There may be a limit set on the Modbus IO size. You will need the Anybus Confguration Manager - X-gateway to change the size. It’s in the software section of the product page.


#6

You will want your config to look like this:

Connect with USB cable to X-gateway, go to Online, Select Connection, to find your COM port, then go Online and Download.


#7

That worked, thank you!