Can I remotely program an AB Micro850 through an Flexy205?

I have been trying to connect to a Micro850 with Connected Components Workbench (AB programming software) through a Flexy205 without success. Can someone suggest what I might be doing wrong?

Through eCatcher I enabled PLC discovery in the Configure LAN Devices menu, and in CCW changed the driver of the AB-ETHIP-1 to TAP-Windows adapter V9 as per the Ewon Application Note AUG-0035-00. When I open the discovery window in CCW, it cannot find the PLC at 192.168.154.100, eventhough it does show up as a LAN device in eCatcher.
image
image

Any suggestions are appreciated!
Thanks

Hi There,
I see your PLC at the LAN devices list, but can you successfully ping it?
Also, what type of communication are you using to connect to your PLC? Serial, Ethernet?
Have you tried rebooting your PLC?

Thanks,
Juliana

Sorry, I should have included that detail - no I cannot ping it from my computer remotely. However, I can ping it from the computer connected locally to the system. The system consists of a Rockwell Stratix switch with four ethernet connections to other devices: the Micro850, a local Industrial PC, an instrumentation transmitter, and the Ewon Flexy 205.

No, I have not tried rebooting the PLC since it is at a remote location and I’m unable to have someone do so locally.

As a side note, I attempted to log a tag in the Ewon from the PLC via the ABLOGIX server and was also unsuccessful.

Thanks

If the 850 is in the same family as the 820 you can not use the ABLOGIX IO server you need to use modbus.

https://techforum.ewon.biz/thread-1586.html

Hi @bdabkows,

@tedsch is correct. For Micro850 PLC you would need to use the modbus IO server on your flexy.

Let me know if it works fine.

Thanks,
Juliana

Thanks for the tip on Modbus IO server, I will try that. However, I’m still struggling with the original problem of not being able to access the Micro850 remotely through the eWON.

I can’t ping the Micro850 from my remote computer, but can ping it from a computer local to the Micro850 and eWON Flexy 205. It seems that there may be a setting in the eWON that is blocking the external communication, what could that be and how can I change it?

Thanks again for your help.

Hi @bdabkows,

You can try the following: go to the flexy’s configuration page → system → communication → routing and then select the enable box next to NAT 1:1. Next, click on the mapping dropdown menu and select NAT 1:1 on WAN → click update and the reboot the flexy.
This setting should allow you to reach your device behind your flexy.
Also, you can look at this post here as a reference as it has a more detailed explanation.
https://forum.hms-networks.com/t/nat-1-1-on-the-flexy/303/2?u=juliana_hms