CAN-IB400/PCI Blue Screen at driver installation

I wanted to install a new CAN-IB400/PCI card on my Windows 10 Machine-PC.
Unfortunately the card is not found automatically.
Installing the card as legacy device results in a Windows blue screen.

What failes: vci4111w5.sys

I tried also to install the card at Windows 7. Windows 7 recognized new hardware but
there was also a blues screen at driver installation.

Hi @itr,

Did you try installing the drivers from this page?

Hello Tim,

I tried with VCI 4 version 4.0.920.0 which was available last friday.
As this version was not available anymore today I tried again on Windows 7 with version 4.0.911.0. This is the version from the link you posted in your reply.

Did this one also cause a blue screen?

Yes, it does.

I think we should focus on Windows 10, as we will not use the card with Windows 7.
This was just a test if the card shows any response. Actually there is no response from the card
in Windows 7 as well as in Windows 10.

My Windows 10 System:

Beckhoff IPC C5102-0060
Intel Core i7-4770TE
Windows 10 Enterprise 2016 LTSB 64-bit

VCI 4 V4.0.911.0 is installed.

The Hardware Manager does not recognize the card at all. There is no difference after startup whether the car is plugged in or not. The Hardware Manager does not show up.
When I add the card as legacy device in device manager with IB400 driver I get the Bluescreen.
This behavior is the same on Windows 7 and Window 10.

The card is brand new, so I can’t hardly imagine that the card itself is defect.

Attached you can find some screenshots and images.

I’ll escalate this with our development team in Sweden and see what we can find out for you. You should be getting an email about the escalation soon

Thank you, Tim.

To eliminate the possibility of a hardware defect our purchasing is ordering a second card as well.

Here’s what my colleague suggested:

“Please deactivate the native PCIe control using the attached bat file and let me know if the problem is solved”

Disable-PCIexpressNativeControl.ZIP (384.8 KB)


Hello Tim,

This was the solution!

After disabling the native PCIe control with your batch file and restarting the PC, the card was immediately found and installed successfully.

Thank you for your help.


1 Like

You’re welcome!

Glad to hear we got it working!

Hello Tim,

finally everything is working now and also the communication is ok now.

I was in Corona-Homeoffice and smoebody turned off the 5V bus supply voltage.
Sorry for this.

Thank you for your help!

1 Like

Thank you for the update. I’ll let my colleague know and cancel the escalation