CAN@net NT 200


#1

@anonlmwerdtn
Hi Jordan,

Please send screenshots showing what issues you are having and we will get you some help with them.

Thank you,

Kyle


#3

Kyle,

I think I may have worked through the RED ‘STS’ light I was experiencing while initially setting up the gateway configurator. I am currently running in V4 I believe. Not sure if there is a problem with this or not but at least the light is now blinking Greed instead of Red.

To view any communication on the CAN I use CanAnalyzer3 Mini is that correct? Just the basic free software I assume? This is a pretty minimal setup I would imagine compared to linking several gates together ext.

When I open mini3 I see the following: NO IXXAT Controllers.

AT the time the gateway CAN@NET NT200 is connected to my laptop with the mini usb. What do I do to find the controller?

Thanks.


#4

#6

Hi Jordan,

The RED Status LED was likely due to the mismatch of versions. I would recommend updating to v5. The firmware and instructions can be found here:

https://www.ixxat.com/support/file-and-documents-download/software-firmware-updates

Yes, you can use the CanAnalyzer3 Mini to view the communication on the CAN bus. The reason you aren’t seeing anything is because you aren’t yet connected to the CAN bus. I am hoping that after you upgrade, you will be able to see the CAN@net NT over the USB, but you can also try to use ethernet. Once it is configured you should be able to see the CAN bus over ethernet. (If you have a USB-to-CAN adapter you can connect to the CAN bus at any time.)

Let me know how it goes and if I can help.

Kyle


#7

Kyle,

The instructions indicate that I am supposed to: “Use the VCI flash loader VCI4floadGUI.exe in C:\ProgramFiles\HMS\IxxatVCI4.0 to flash the intermediate firmware image to the device:”

I don’t have this, nor can I locate it on the website.


#8

Have you installed the VCI v4 driver?

If so, it should be in [Program Files\HMS\IXXAT VCI 4.0]

If it’s not, please reinstall here.


#9

Yes I installed that driver, that is how I got the CanAnalyzer3 mini, they were together in that package. However, the path is not the same. Ixxat VCI/Ixxat VCI 4.0/

Jordan


#10

I believe part of the problem is that there is not a complete set of instructions. 1 manual tells you to go to another and visa versa, however one is not completely sure when you are supposed to jump back to the ‘other’ set of instructions that told you to get to where you currently are.

I installed the driver first. VCI4 as instructed by this document step 3:

https://www.ixxat.com/docs/librariesprovider8/default-document-library/downloads/vci-v3/4-02-0250-20010-vci-en-a4.pdf?sfvrsn=4987bed6_28

I did not use the CD rom I downloaded the package from the link from the above Pdf. I did not select any additional components during the install because I didn’t know if any extra stuff was necessary for basic function.

Step 4 Install the interface:

I don’t know what this is referring to, nor do I have any idea what the ‘hardware manager’ is, it did NOT boot automatically as the instruction indicate.

I have not done anything with the next step (4.2) regarding the CAN@NET NT Device Server control.

Jordan


#11

Kyle,

I found the loader, I was following the windows start tree instead of looking through the actual directories. I followed the directions and have updated the firmware to V5.

I ran the configurator with the selected ‘v5’ config and have a green STS light (blinking 1 hz). I still cannot see anything with CanAnalyzer3 mini. What should I do next?

Jordan


#12

Are you able to scan and find the device yet in the Gateway Confgurator?

If USB isn’t working please try ethernet.


#13

Yes,

I can scan and the device is found. I can also connect there (looks like a chain symbol)


#14

Kyle,

From the VCI driver install manual, step 4.2.1 ‘install interface’: the 2nd carrot > install interface, which interface?

3rd > Boot Windows, hardware wizard starts. This did not happen. However the driver is visible in the device manager, not sure if this is what the manual is referring to as the ‘interface’ or not.

Next step seems to be 4.2.2 Install CAN@net II. So I open the ‘server control’ and add the device and enter the current IP address and name of device as displayed in the gateway configurator. When I select ‘start’ I get errors and two purple <> this continues infinitely until I select ‘stop’.

I assume that I have missed a step somewhere?

Jordan


#15

Do you have it set to VCI Interface mode in the CAN GW Configurator and the IP address is set? (I assume you are doing the VCI Interface mode)
Did you set the information in the config tree (General - Author, Config Name, etc.) and then write to the device? (Icon with red down arrow)


#16

Kyle,

I am in ASCII Gateway Mode, yes I set all the below mentioned items before writing to the device. Before that was done was went I was experiencing the red STS light, (because no config was written to the device yet).

Jordan


#17

Would you recommend VCI interface mode for this setup?

Jordan


#18

Hi Jordan,

If you are using ASCII Gateway Mode you should be done with the config and be able to communicate with ASCII commands. See the Software Design Guide.

I can’t make a recommendation on your setup because I don’t know anything about your application or even what devices you are connecting to at this point.

Kyle


#19

Kyle,
My goal is to view CAN bus data from a delphi NH3 sensor 28340830.

At what point should I be able to see the Device on the Device Server Control? I continue to get ‘failed to start’ errors. This is step 4.2.2 from the ‘VCI Driver’ manual, there is no additional help from the manual in the event that the device doesn’t start. If I understand correctly this needs to be in place before you can see anything with CanAnalyzer3 mini. This is the last check for the ‘troubleshooting’ if you can call it that from the canAnalyzer3 mini program when you start it.

Ultimately a linux program will be performing the ASCII commands in an automated fashion. Right now I want to iron out all the connectivity issues.

What other information do you need before you would suggest another step?

Jordan


#20

You may get an email from our ticketing system because I’m escalating this to my colleagues at the IXXAT office who should have a better idea of what you’ll need to do. They’re in Germany so we’ll have to wait until early tomorrow AM for a response.

What version of Windows are you using? From an above screenshot it looked like a version of 7.


#21

They are going to want me to make sure your CAN Bus is wired (and terminated) correctly. Have you checked this with a multimeter and made sure you have the right voltage and resistors installed?


#22

Correct, Windows 7 professional.