Cannot access registers within Anybus 7072 module


#1

Hi there,

I have a series of Arduino’s which are daisy-chained together on RS485, which then are connected to the serial port of the Anybus 7072 module.
The Arduino’s comminicate well with the Anybus module, and I am able to see the correct registers and value when I perform a Node Monitor.

The issue is coming in where I want to read these holding registers from the Anybus. I am connected via ethernet port 2 to an HMI (Red Lion) which is set up to read the registers from the Anybus module.
I am able to see when the Anybus device is online/offline by cycling power on it and seeing the HMI’s response.
I cannot access the register values from the Anybus. I have tried using a Modbus simulator to read register blocks to see whether there is an offset which I’m not aware of.
I have the ethernet cable between my PC and the Anybus connected via port 1.

Is there perhaps anyone who can help me?


#2

Hi @k.alexahearn,

The connection to the Ethernet side of the communicator is typically set up using the EDS file we provide. Do I understand correctly that you are trying to use Modbus-TCP instead of Ethernet/IP? If so, what commands are you sending and what responses/errors are you receiving? Do you have ModbusTCP address mode enabled in the Fieldbus settings in the configuration manager?

Can you share your .cfg file so I can take a look at it?

Thanks,

Kyle


#4

Hi Kyle,

Thanks for the response!
I’ve attached my Configuration Manager file for my set up.
As far as I understand yes I am using Modbus TCP/IP via Ethernet cable (as NIC) to a Red Lion HMI (which uses Crimson 3.0 software to set up).

I have it set as Ethernet/IP & Modbus TCP/IP 2 port as that is the model function.

CO2 TEST3.cfg (16 KB)


#5

#6

If you can connect your HMI to the Anybus using Ethernet/IP that would be preferable. Most EIP scanners or masters will allow you to add the adapter using the EDS file.

Is that an option?


#7

Were you able to use Ethernet/IP with the HMI?

If not, you can still use Modbus TCP. You are going to want to read holding registers starting at 40001 and up.

If you need additional help, you can also create a ticket with your local HMS office by visiting https://mysupport.hms.se

Thank you!

Kyle


#8

Also, if you are going to use ModbusTCP the EIP Run/Idle Header should be disabled.


#9

Hi Kyle!

So sorry for the delayed response.
We tried setting up as a Ethernet/IP but we cannot run an adapter file so unfortunately that isn’t an option for us.

But the Online/Offline trigger actually was enabled so perhaps this is the problem. I will check shortly and let you know.
Does the Communicator IP address have to be the IP address of the Anybus Communicator Module? Or of the HMI it is communicating with?

Is there any additional set up to be done in the list under the ‘Fieldbus’? StartInit, AnybusInit, etc?

This is what the current set up looks like now:
image

Thank you.


#10

The Communicator IP address should be set to the address of the Anybus Communicator. You do not need to make any changes to the expanded Fieldbus settings. Your current settings look good. You should be able to poll the registers with Modbus commands now.