CANopen master not responding to Controlword


#1

@anonduqwztov
Hello Shawn,

I will reach back out to you through this topic once i have been able to test this.

Deryck


#4

Hello Shawn,

I am still working on setting up a test bench but there was one thing we didn’t check. Perhaps the byte order is backwards. Try setting it into run mode with where bit 7 in Studio is the least significant and 0 the most.

Deryck
@anonduqwztov


#5

Hi Deryck,

I did try that with no difference, but will try again.

Thanks,

Shawn


#6

#7

#8

I checked again, but no luck.


#9

Hello Shawn,

I thing i found out what was going on.
First you need to make sure the application is setting it to operational mode.
image

Then this will allow the PLC to set the network in and out of operational state.

Then from the PLC you need to set byte 1 to either the specific nodes, or in your case 0x80 for all noded.

To set it to operational you need to first set the mode you want this is the last 4 bits of byte 0. for these for bits 7 is the lest significant. setting this to a 1 then toggling bit 0 will set this mode. Setting bit 7 back to 0 and toggling bit 0 will set it to per-operation. This would be the same as setting byte 0 to 0x01 then to 0x81 for operational mode. Setting it then to 0x80 then 0x00 will go into pre-op.
Let me know if this clears things up for you.
Deryck


#10

Hi Deryck,

I see what you are saying. I checked the settings and tried the commands as you recommended, but no change in states on the Gateway.

Will you be able to Team Viewer in and try it. Maybe, I am doing something wrong.

ID: 216 176 574

PW: t916jh

Thanks,

Shawn


#11

Hi I have some time between now and 5 I can jump on. What is your number? I will give you a call.

Deryck


#12

My number is

Ready when you are