Can't reach LAN devices through eCatcher


I am having trouble connecting to S7 1200 PLC, I have set up Talk2M account, copied registration number to EWON, I have opened eCatcher and I have an Active connection on first and second attempt, could not connect to PLC using TALK2M Ecatcher network adapter, on third attempt I received an ip address overlap message. I have enabled network discovery on EWON, Configure LAN devices and Firewall is greyed out under Ewon Properties.

Any ideas?

I have attached a few screenshots,thanks for any help in advance.

Is your local network on the same subnet as the Ewon’s LAN?

Do you have admin rights for the eCatcher account?

Hi Kyle.

I have obtained admin rights and added all LAN devices, but I’m still unable to connect.
I have attached another screenshot.
Any ideas, thanks in advance for any help.

can you show the results of the ‘route print’ command after connecting to the Ewon?

Hi Kyle.

Please see attached <route print -4> result.

You need to change NATItf to 3 NAT on LAN (Plug n Route). Right now it’s disabled. (In Routing section).

Keep in mind if y ou are trying to connect from a network with that same subnet address (192.168.0.x), you are going to have IP conflict issues. I recommend staying away from common subnet addresses like that.

Hi Kyle.

Thank you for your prompt response.

I am a little confused as to the 192.168.0.x subnet you mentioned. I think it could have been my VM’s, as far as I can tell the tap 9 eCatcher gateway ip address was, is that correct, if so how would the 192.168.0.x influence the result.

Yes, I’m sorry. I must have been looking at the wrong backup. Can you make a backup of the Ewon with eBuddy and check the box “include support files” and attach that to your response so that I can take a look at the logs and settings?

Hi Kyle.
Ewon back up as requeted from Ebuddy.


Please change NATItf to 3:

You MUST REBOOT the Ewon after making the changes!


Hi Kyle.

I have rebooted but the change wont stay, I tried twice and natltf reverts to 0 after reboot and I still can’t get online.
Any ideas?

OK, Please change ‘RTEnIpFwrd’ first to 1, and then change ‘NATItf’ to 3 and reboot.

By any chance, did you restore this configuration from a backup?

Hi Kyle.

It works! Thank you very much, btw it wasn’t saved from a back up.

Great! Let me know if you have any other issues.