CM CANopen download problem

Hi everyone,

One of my customer wants to download his last configuration to cm canopen without changing any data in it. however he encountered an error message that shown below:

also the leds are blinking like shown in video:

while the download procedure happens, the plc is in stop and offline position.
what could be the possible solution for that?


there are several possible reasons:
TIA Portal: Device configuration

  • CANopen Manager auto configuration: must not be activated

TIA Portal:

  • a running SDO command from the PLC
    all running SDO commands must have been completed and a new one must not be started when the configuration shall be downloaded to the CM CANopen

ERR LED of the CM CANopen:
single flash: CAN Controller: warning limit reached
Possible reasons:

  • check if the CAN bus is terminated correctly:
    see manual of the CM CANopen: chapter 4.4 Line Termination
    there must be exactly 2 resitors with 120  (5%, 1/4 W max.)

  • there is not a connected CANopen device

  • CM CANopen and the other CANopen module(s) have reached warning level set
    note: power on
    the time of the CANopen initialization after power on until the device has started its CAN Controller depends of the module
    when this time is too different it can happen
    that the fastest module has entered warning level reached before another device has started its CAN controller
    => it depends of the CAN controller if it confirms the successful reception of a CAN message or not when in warning level reached
    so the bootup message of the next device will not be configrmed and the device will also enter warning level reached

    so each one is waiting for a confirmation and the processing is stuck

1 Like

Hi Kyle,

Problem is solved. As they renew the cable line, they forgot to put termination at the end so they put the termination the end of the can line and problem is solved.


Ah ok good. I had posted the above before I saw your reply. Thanks for the update!