Connection from Virtual Machine

I am trying to connect to a PLC through eWon Cosy. I can connect with my host machine, however we typically run all of our programming software in virtual machines(VMs) to avoid having multiple programming softwares installed directly on our host machines, but I’d also rather have the eCatcher Software installed on the host so I don’t have to install multiple times.

Is there a way to configure the VM network connection so that it uses the eWon VPN?

This should be possible, but if I’m understanding the question correctly than it depends on the hypervisor, not the eCatcher software. eCatcher creates a TAP adapter on the PC, and the hypervisor or virtual networking software should be able to bridge a VM’s network adapter to the TAP adapter on the host.

What is the hypervisor you are using? VMWare, HyperV, etc.

I’m using VMWare. I did try bridging, and was able to ping the TAP adapter, but when I ping the Cosy or the remote device I get no response.

The key might be knowing what address and gateway to use on the VM. I tried using addresses similar to the WAN address of the Cosy / Address of the TAP adapter, and I tried using an address like the LAN address of the Cosy Side. No luck on either of those.

My addresses:
TAP 10.213.29.X
255.255.0.0
No Gateway specified.
Cosy WAN
10.213.165.x
No Gateway specified
Cosy LAN
10.0.0.x
255.255.255.0

So on the VM I tried

  1. 10.213.29.X (but different than above)
    255.255.0.0
    No Gateway specified

  2. 10.213.29.X (but different than above)
    255.255.0.0
    TAP address as Gateway

  3. 10.213.29.X (but different than above)
    255.255.0.0
    Cosy WAN as Gateway

  4. 10.0.0.x (but different than above)
    255.255.255.0
    Cosy LAN as Gateway

None of those worked.

Hi @cbohon

I don’t think the problem is with the IP address of the VM. The primary network adapter on the VM should be in a different subnet than the Cosy or TAP adapter.

The WAN address you set on the Cosy is conflicting with the address of the TAP adapter and our VPN servers. Please pick a completely different subnet for the Cosy’s WAN.

I’m somewhat familiar with VMWare networking, but certainly not an expert. I think you should be able to create a bridge to the host TAP adapter and use that for the VM. I will look it up, but please fix the WAN address on Cosy and try that.

Thanks,

Kyle

I misstated what that address is… its actually the VPN IP address, not the WAN address. And I can ping things on the other side with the Host computer, just not the VM.

Is this PLC remote to you? I want to make sure I understand exactly what you are doing.

Keep in mind that if you are connecting to the PLC using eCatcher on the host, eCatcher will also need to connected in order to connect to the PLC from the VM. I may need to call and do a remote TeamViewer session to see exactly how you have this set up.

Kyle

The PLC is logically remote to me. I put it and the eWon LAN on a different network than what my computer is connected to. But the WAN network and my computer are the same. I figured this would work to test because the VPN tunnel will separate my computer from the eWon.

I PMed you my info to call me.

Hi Caleb,

I’ve been looking at this and I think we are going to be limited by the host OS being a Windows PC and the inability to bridge to a Windows TAP adapter. The virtual machines need to use the host machine as a router. I think it would be easier to accomplish this (using the host OpenVPN client connection as a network adapter on the VM) if the host system was Linux.

Have you had any luck at all?

Kyle

No, luck yet. Changing the hosts to Linux is not possible at this time.

I was saying that more hypothetically anyway, as we don’t have an eCatcher version for Linux anyway. I don’t think this is going to be possible by bridging the Windows TAP adapter like you would do with a physical network adapter. Maybe something could be created using Windows server as a router and the VPN client, but that’s a long shot.

use NAT setup is working for me. Not Bridge.

Topic closed due to inactivity.

CBOHON,
I ran into the same issue that you described and did the exact same troubleshooting but still nothing… were you ever able to resolve this issue? Please let me know

I think the issue people are having is that the host adapter that they are trying to bridge to is not on the correct network. Make sure the host adapter is in the same subnet and connected to the same network as the Ewon.

By the way, you cannot bridge to the Windows TAP adapter if that is what you’re trying to do.

I ended up just installing the software in my VM. I don’t use it often enough to need it on the host.

I have the same problem. ecatcher on host and step7 on vm. how did you solve?

I ended up just installing the software in my VM. I don’t use it often enough to need it on the host.

ok, so the solution is not there yet