Cosy 131 4G NA AT&T APN Settings

This isn’t a question; I’m posting a resolution for anyone searching the forums with the same problems I had but didn’t post:

Received an eWON Cosy 131 4G NA model (EC6133H) with the included AT&T SIM card. Successfully registered the SIM to a prepaid account directly with AT&T, but could not get the unit to connect using “Broadband” as the APN (as there are countless posts on here recommending). Only information in any logs were plenty of “GPRS attach operation failed” errors. Tested with my cell phone’s SIM (Google Fi) and it connected without issues, and tested the included AT&T SIM in my cell phone with no connection issues either. Noted that my phone automatically used the “NXTGENPHONE” APN.

Thinking it was something with the settings, I tried pretty much every APN listed online for AT&T and any carriers they bought out, but couldn’t get anywhere. After finally giving up, I ended up taking the unit and a 24V wall wart to an AT&T store to get things figured out. They got a new 5G SIM card, registered the SIM notably without using the IMEI from the eWON unit (I don’t know if you can do this yourself online, but it probably doesn’t matter) and I tested it using “Broadband” as the APN only to get the same error previously mentioned. Switched the APN to NXTGENPHONE and the unit connected without issues.

The guy I was working with was thinking that AT&T was forcing new activations to use the NXTGENPHONE APN-something the included SIM card didn’t support outside of smartphones, and switching to the current 5G SIM they provide (even though the eWON can’t use 5G) solved the issue. I doubt the solution had anything to do with the AT&T employee being able to activate the SIM without an IMEI, but its worth mentioning if you have gone down the same path on your own and it still doesn’t work.

I haven’t seen using “NXGENPHONE” as an APN for AT&T anywhere on here, and it has to be input as a custom APN as of 14.5s0, so I figured I’d post all this to help anyone stuck in the same situation.

Hi @mmillerDL ,

The sim card provided is preconfigured to work with our sim card provider. The activation portal url should be printed on the document provided with the sim card. They required being activated on the portal using the ewons. So i think getting a sim card directly from ATT is what resolved your issue. I believe just activating the sim card with ATT should have failed since it was already provisioned.