Cosy and Cognex


#1

Hello,

We are trying to access a Cognex Insight camera via eCatcher through a Cosy 131 with Wifi. However, we are running into a few issues.

The eWON and Camera are on the same subnet. The eWON can be connected to via eCatcher and we can ping the Camera, but the eWON webserver will not load and the Camera doesn’t show up in the software. We are not onsite with this device thus cannot force a power cycle. It is also interesting the ewON does not show up in eBuddy, so I do not know what firmware version it is, and I cannot update the firmware.

Problems:

  1. eWON webserver does not load, whether typing in actual IP address or VPN IP address.
  2. Cognex IS camera will not show up in software.

Things I’ve tried:

  1. Turning off all Firewall
  2. Searching for camera in software
  3. Directly entering camera IP address in software using the Host Table
  4. In eCatcher, added a LAN device under ewon’s properties to specifically highly the IP address we want to connect to. Disconnected and reconnected from eCatcher
  5. Tried 2 separate computers

I know there are a few things we can try by changing the settings on the eWON’s webserver, but as i mentioned we cannot load it.

What are your thoughts?

Thank you!


#2

Can you ping the eWON? Try VPN and LAN address.

When you say the eWON webserver doesn’t load, do you get an error?

Are you using the latest version of eCatcher (version 6.4.1)?

What is the eCatcher firewall setting?

Have you tried connecting from a different network (cellular hotspot vs corporate network, for example)? Tried a different browser?

Can you log in with M2Web?


#4

Hey Kyle,

I can ping the eWON’s LAN. The VPN address consistently gets 2 out of the 4 packets, so only have of the pings respond.

We do not get an error when the webserver doesn’t load, it literally is just stuck on a white screen that says “Loading…”

eCatcher version was 6.3.7. I just now updated it to version 6.4.1. Same result as before, successful connection, but cannot actual view the webserver or see the camera.

Same results come from M2Web.

Same results from a different browser.

Same results from a different network.

I was successfully able to connect to the camera! Thank you.

For me, the firewall setting needed to be set to High using the latest version of eCatcher and adding the camera device using the Host Table.

I’d still like to know why we cannot get into that webserver though. Any thoughts on that?


#5

It might just be locked up and needs a reboot or there could be another issue. Was there a ViewON page loaded onto the device?

Try using http://X.X.X.X/index.shtm in the browser.


#6

There is no way to remotely reboot it if we can’t get into the webserver, correct? That URL did not work when using its IP address.

There is no ViewON page, I thought only the Flexys had viewON pages as an option?

~Nick~


#8

Yes, you are correct. There is no way to reboot it if you can’t log into the webserver or contact with eBuddy, unfortunately. And you’re right that only Flexy has ViewON, I was thinking this was a Flexy for a moment. You’ll have to get someone to power cycle it.


#9

We will have someone local do that.

Thank you!