Could not load file or assembly 'vcinet2'


#1

I’m using a tool developed internally which is using the IXXAT drivers for a USB-to-CAN compact. For this I’ve installed VCI V4 (4.0.848.0) and also the VCI V2 on V4 (2.30.72.0). When I open the application I get the following error:

“Could not load file or assembly ‘vcinet2, Version=3.5.71.0, Culture=neutral, PublicKeyToken=1fb9dc3563e138e2’ or one of its dependencies. An attempt was made to load a program with an incorrect format.”

I’ve checked the folder the application I’m using and it’s using the version described above. The file is 97.096 bytes (98.304 bytes on disk). The one at ‘C:\Program Files\HMS\Ixxat VCI\intern\dotnet_vci3’ is 106.504 bytes (110.592 bytes on disk).

What I notice is that the dll is installed at ‘C:\Program Files\HMS’ while the rest of the driver is installed at ‘C:\Program Files (x86)\HMS’.

Right now I’m stuck without any solution which is bothering me for over a day now.


#2

It looks like you may not have uninstalled VCI V3 before installing VCI V4. I would uninstall all VCI apps and reinstall VCI V4.


#4

I’ve got this error message the first time I installed V4. After these initial errors I’v tried to install V2, V3, V4 with V2 for V4, always letting the installer remove the old version and installing the new version. So I’m quite sure I did remove V3 during V4 install but not before. I’ve also tried removing all version in Windows Programs window and installing V4 and V2 for V4 again but still the same error.


#5

Have you checked with the developer of the application? They would be your best resource, followed by your local IXXAT support team in the EU.


#6

Our local developer who’s maintaining the application right now is not able to fix it. Who or how can I contact local EU support?


#7

Could is possible be a problem with 32 bit and 64 bit versions of the .dll?


#8

Please click here to log in to the Online Support Tool or you can create a new account.