DNS resolution on nat

Hi all,
I’m struggling with ah issue related to dns resolution on my configuration.

I need to have internet access to my lan devices on an eWon Flexy 205, so i configured NAT and TF forwarding over the WAN then enabled the security setting for forwarding all traffic from LAN to WAN.

The issue is related to DNS resolution. Infact using both public dns or private dns on WAN side, the lan devices doesn’t have pure internet connection (the ping from lan device to a public dns works but a ping to “www.googl.it” doesn’t).
The strange thing is that if I use the same configuration on another network, everything work properly. I have this issue only with a specific customer network (so I’m presuming an issue on customer’s network).

Does anyone have managed the same issue somewhere?

Hello there,

Are you sure about this address “www.googl.it” you are using? Have you tried another public DNS?
All your settings seem correct, this could be an issue with your costumer’s network just as you suspected.

Also what kind of devices do you have on the LAN side of your ewon? Have you setup the ewon as the gateway of such devices?

Thanks in advance,

Hello Juliana,

Sorry i mistyped “www.google.it”. Unfortunatelly I didn’t try with ther public DNS (just and

On LAN side of the Ewon I have 2 devices (PLC and HMI) and yes, i setup the ewon as their gateway.

Have you other suggestion or any known issues with wan side devices?


Hello there,
Do the PLC and HMI use a static IP address? If so, they need to have a DNS server set in their settings . It sounds like you set the default gateway, but didn’t set a DNS server (in the machine, not the Ewon). Can you confirm?

The Ewon will only pass on the DNS server to use if it is also acting as a DHCP server, and the machine is configured to DHCP, not static.

Also, since you tried on a different network and it worked fine, something in your customer’s firewall could be preventing the ewon from reaching the internet. It wouldn’t hurt to take a look at this document kb-0209-00-en-adresses-and-ports-used-by-talk2m.pdf (windows.net).


Yes, the PLC and HMI are both setted with static IP address since ewon has no DHCP server on lan side by default.

The ewon is able to connect to Talk2M, just the devices (HMI) in LAN side can’t access internet even though the DNS is public or private.

I performed the Talk2M connectivity test. This is the result (attachment) but i guess the issue is not related with the result.


Hi There,

Can you send a backup with support files of your ewon please?


Hi Juliana,

Now I’m not able to send you the support files because the ewon isn’t reachable through internet and it’s installed to our customer.

Hopefully I’ll be able to take those next week so i’ll post here

Thanks in advance for your support