eCatcher Error after Update to 6.7.10

The Windows Talk2M VPN Service cannot be found. Please check in the control panel if it is running or restart your computer. No known network firewalls, ECT. Other Computers on 6.7.10 run correctly on same network…

All services are running eCatcher just cannot find them. Uninstall and to and revert to 6.7.3 did not cure issue.

This is usually the result of a problem with the installation, often caused by an antivirus software. Please uninstall eCatcher, disable your anti-virus, and re-install “As Administrator”.

No Anti-Virus Uninstalled eCatcher, Still the same issue.

More Info to add, I just found Windows Security and turned it off. Uninstalled eCatcher, Rebooted, Reinstalled eCatcher. the first time the program started it worked. I closed it and the second time I got the error again.

There is a Windows Service called Talk2M VPN Service installed with eCatcher and the communication between eCatcher interface and this service is done through a Telnet Internal Socket. The error you are seeing means this socket cannot be established either because the service is not installed or running or the Telnet connection is blocked by something.
Are you sure there is no other security settings? Are you on a domain PC? Have you tried with another PC on the same network?

There are no other Security settings that I can find, Yes we are on a domain, the other PC on my desk is nearly identical but is older and it does run fine. Both are Runing Win 11.

just started getting another odd error… This is from OpenVPN GUI

No readable connection profiles (config files) found. Use the “Import File…” menu or Copy your config Files to “C:\Users\OpenVPN\config” or “C:\Program Files\OpenVPN\config” Not sure this relates to you but I beleve you use Open VPN in your Connection.

Yes, we do use OpenVPN. Are you using the OpenVPN GUI for another VPN? It’s possible that these are interfering with each other depending on how it was installed.

Unless Real VNC uses OpenVPN I do not think so.

Real VNC does not use OpenVPN, but can be used over an OpenVPN connection. I would recommend uninstalling the OpenVPN GUI. You may need to re-run the eCatcher installer after, or run the scripts in the ‘C:\Program Files (x86)\eCatcher-Talk2M\Talk2mVpnService\drivers’ directory in the following order:

  1. deltapall.bat (as admin)
  2. addtap.bat (as admin)
  3. renametap.vbs

Make sure in your Network Adapters, there is a TAP Adapter called ‘Talk2m-eCatcher’ and if there is not, please rename it.