eCatcher TAP Adapter VPN Tunnel error

How do I fix this eCatcher VPN Tunnel error?

Tap Adapter errors:

  1. “VPN tunnel error: When using –ip-win32 netsh, if you have more than one…”

    This error occurs when you try to connect to your Ewon and there are more than one TAP adapters configured on your PC (you could have another VPN, for example). eCatcher can’t tell which one to use.
  2. “VPN Tunnel error: TAP-Windows adapter ‘talk2M-eCatcher’ not found”
    This error occurs when you try to connect to your Ewon, but eCatcher can’t find the correct TAP adapter.
  3. “VPN tunnel error:CreateFile failed on TAP device:.\Global####.tap:General failure{ERROR_GEN_FAILURE)”
    -This error is normally caused by a Windows permissions issue.
    -This issue can normally be solved by logging out of Windows and logging back in. If that doesn’t work, you may need to uninstall and re-install eCatcher entirely. Make sure to reboot the PC after.


  1. The first 2 errors are normally caused because the name of the TAP adapter is not correct. Check in you Network Connections (Control Panel\Network and Internet\Network Connections) that you have a TAP adapter called “Talk2m-eCatcher”:
  2. If the name is not correct, right click and select “Rename” to rename the TAP adapter. Restart eCatcher and try to connect. If the problem persists, continue to step 3.
  3. Make sure that you are running the latest version of eCatcher. You can find the latest version here. If an update is required, make sure to remove the previous version. Reboot the PC and try to connect. If it fails, move to step 4.
  4. In the following directory, there are some scripts that you can run to delete, re-install, and rename your TAP adapters: C:\Program Files (x86)\eCatcher-Talk2M\Talk2mVpnService\drivers
  5. Right click “deltapall.bat” and Run as Administrator.
  6. Right click “addtap.bat” and Run as Administrator.
  7. Now double click on “renametap.vbs”. This should rename the TAP adapter, but you should double check that it worked and if it did not, rename it manually.
  8. If the problem persists, log out of eCatcher and click on “Settings” on the log in page.
  9. Click on “Modify” in the “VPN Driver Settings” section.
  10. Try switching the IP assignment method (If “Netsh” is selected, try “DHCP” and vice versa.
  11. Log back into eCatcher and try to connect again.
  12. If the problem persists, try completely uninstalling eCatcher, rebooting the PC, reinstall eCatcher, reboot the PC, and then try to reconnect.

Forum post highlighting OpenVPN software conflicting with eCatcher.

A post was split to a new topic: Getting VPN tunnel error and tunner error guide did not work

Hi kyle_HMS,
I installed eCather 6.10.0, and keep getting an error when connect to the remote, “VPN tunnel error: No TAP-Win32 adapter was found on your system. please reinstall eCatcher”, even after another round of download and install.

I checked and found no “Driver” folder under “C:\Program Files (x86)\eCatcher-Talk2M\Talk2mVpnService”.

What should I do to make it work? please help.


Something on your PC is blocking the install. Please disable the anti-virus or whatever is blocking the install, then re-install eCatcher.

You may need to get your IT department to allow eCatcher on your PC.