EN2MB-R setup issues 8/12

hms-en2mb-r

#1

Hello Deryck

Some bad news …

Started to work on EN2MB-R

Working thru the manual

1-insert new module (page 20 my version)

2-create

3-assign name and IP adder

4-bring up “module definition”, click to bring up tag manager

5 tag manager is up. Get some message about no config (expected)

Click the LEFTMOST icon

System appears to hang at this point… task manager says tasks not responding

But if I wait (maybe a minute or two) a new dialog pops up USER AUTHENTICATION

Not sure where this is coming from

Tried CANCEL … system appears to hang for a couple of minutes (task mgr says not responding) … after a few minutes the dialog is back

Tried typing my windows login and pword, click OK … same result

Tried typing nothing, clicking OK … same result

Tried rebooting, starting logix again several times now, same result

Started with a clean copy of the PLC prgroam, did a fresh insert of the HMS module … same result


Create hms-en2pb-r Module issue Studio 5000
#2

Hi,

I pulled this into a new topic as it look unrelated to the AOP. This sounds like an issue with your connection to the device. I have seen similar results when I had another device on the network using the same IP address.

If you disconnect it from the network and then connect your PC directly to it do you still see these issues?

Deryck


#4

I am not even attempting to go online with the unit at this point.
I am trying to make an offline edit, configuration editor is empty.


#5

I tried another laptop

I get the exact same issue with the AUTHENTICATIOn question


#6

?I’m not even at the point of going online

…I thought I was supposed to enter some kind of config offline first


#7

it was totally unclear to me that I had to be online with the gateway (!)

you need to:
-have the gateway powered up
-use BOOTP to set the address of the gateway
-probably check in RSLINX that it can “see” the device
-in RSLogix5000/Studio5000 not be online with the PLC
-then click the button


#8

Couple issues still unclear to me:

-on the side of the unit it says “MAC X2” with the MAC ID --> I would guess this is talking about X2, the bottom connections
-when I run BOOTP, I get this MAC from the FRONT connectors (X1.1 or X1.2) not from X2
-I did manage to use BOOTP to set the X1 (Ethernet/ip) address but the note seems mixed up

  1. How does the IP on the MODBUS side get set?
    I thought it was thru the pseudo webpage (section 7.3.2 page 42) in manual?[/img][/img]
    but I could NOT set anything … couldn’t type in the little box

  2. Some of the dialog boxes were malformed, I couldn’t see the YES or NO buttons
    I can see the top of the buttons, but not the text
    When I clicked on the buttons anyways, nothing happened
    I could see the button border change color (expected) but no action seemed to occur
    EClipboard03

  3. One dialog not matching the manual
    ~?how do I attach an image on this webpage, cant figure it out~


#9


this is the “clipped dialog box” issue
pretty awkward, I can’t tell what’s going on, really blind here


#10

EClipboard01


this one seems minor for now, dialog box actual not matching manual version


#11

Setting the IP address on the MODBUS side

was unable to set here … is there a trick?

If I am supposed to use BOOTP … then the unit only lists ONE MAC address on the side … which seemed to work for the ETHERNET/IP side … very unclear what is MAC for the MODBUS side

am a bit stuck at this point right now

also not sure what to put in as router address if not using router


#12

okay, solved the “setting the Modbus side IP address issue” - pretty easy - just turn off DHCP in the dialog box - this allows the IP address to be set


#13

re the MAC ID issue:
-the text on the label of the unit says MAC X2 but I am positive it is for the Ethernet/IP side, which I would have said is network ONE (not 2)

-to get the MAC of the MODBUS side – it’s displayed on the “home” page of the


#14

so the “unreadable dialog boxes” is my main concern right now


#15

Hello @pmccutcheon,

The configuration does have to be done online with the Linking device but offline with the PLC.

The MAC ID can be found from within the configuration page of the device. It looks like this is a production issue where they are printing the MAC label as “X2” when they are really providing the X1 interface MAC.

With DHCP enabled it will prevent a static IP from being set. You can also use our IPconfig tool to set the ip address. As for the modbus side this is going to be configured thought the Modbus configuration page.

If you would like we can discuss this further over the phone. Please give me a call at 312-893-5636 or provide me a number and I will give you a call.


#16

Hello Deryck

Attached are my notes on the setup.

Maybe some areas for small improvements in the manual

Unit seems to be working

(now have to deal with the 3rd party guy on the other end :wink:

HMS EN2MB-R Gateway Notes.docx (1.31 MB)


#17

Hi @pmccutcheon,

Thanks for the follow up. You make some good suggestions that I will forward to the product manager.

I have already reported a few like the dialog box to them already and hope to see that corrected in the next update.

Deryck


#18

I’ve been a bit picky, but it’s a well packaged unit, well integrated in A-B, the documentation is pretty good, and it seems to be working