I am having trouble with EIP to Modbus TCP from a CompactLogix to a Watlow F4T Temperature Controller. I can read values from the Watlow and write integer data to the Watlow but can’t write floating point values to the Watlow. Is there a way for me to monitor the data string being sent from the EN2MB-R when the message is rejected?

Have you tried the Transaction Monitor?


Yes, but what I need to see is the hex values being sent in the message. I am able to read floating point and integer values in the Watlow but I am not able to write either using Modbus command 16. All values in the Watlow are stored as two 16 bit words and are supposed to be written using command 16. I can write integer values using command 6 and writing to the second of the two words. I have tried different byte and word swap scenarios, but none seem to work.

I would recommend using a Modbus Scanner Simulator like CAS Modbus Scanner, to trouble shoot the messages sent to the Watlow. Once you get the commands perfected, you can copy them into the Anybus.

I have a similar problem with the Watlow controller. The monitor shows ‘Transaction error (Modbus Exception), no data to display. Exception code 4 (Slave Device Failure)’ I think the Watlow has a different protocol definition for Modbus communications.


This is a modbus error response back from the modbus TCP server. This tell us the gateway is sending a modbus request to the device and it is responding but it is an error. You will need to look at the slave/server for details.



Thank you for your response. Given the frustration I have been going through to get this operational, I took a different approach. I was able to write a eModbus routine that works natively in the Allen Bradley PLC and I no longer need the Anybus.

Again. Thank you for your support.