EN2SE-R Generic Data

I have an EN2SE-R connected to a CompactLogix PLC.
It appears to be operating properly when I connect a loopback plug to the Serial port; The characters are echoed as expected and I capture the data after the Trigger Byte is incremented. All is good there.
If I connect the Serial Port to my computer running PuTTY, I get no data in the Consume tags and the Trigger byte is not incremented.
I have confirmed that PuTTY is sending the characters by attaching the loopback to the PC and observing the echoed characters on the terminal display.
Any suggestions?

Does the trigger send a command to the serial device or do you just have the consume transaction? I would try cyclical to see if you get the data.

Can you share the manual?

I have to say that this device is very frustrating.

The documentation leaves just enough out to make the user guess about how it handles data.

Then the lack of support only adds to the frustration.

I have a very simple application that should take a very short time to configure and implement.

A brief conversation would have resolved this in minutes. Instead, I struggle for hours waiting for a response from HMS.

Is this the nature of the support that I can expect?


After some digging, I changed the Data in the Produce and Consumed locations to Variable length.

This resulted in the trigger byte being incremented, but the data is still not getting through. Invalid Message in the Subnetwork Status.

The thing is, that I do see the data in the Log, so??

I consider this progress. Attached is the configuration file as it is currently set up…


CP300_EN2SER.cfg (16 KB)

I send the Variable Length data out the serial port using the Produce Trigger Byte, and the Output from the serial port works fine. The problem is the response.
The Device is transferring only one character from the Variable Data to the process tag and then incrementing the Consume Trigger.
I then set the End Character Value to 16#0D (CR) and the Object Delimiter to End Character Visible. That resulted in the device to send only the last character in the input buffer and then the CR.
The Devie that I am trying to integrate will send a respond delimited with a CR, so, by Setting the End Character Value and Object Delimiter to End Character Visible, shouldn’t that hold the entire variable data until the CR is seen??

Have you called support for this (312-893-5636)? It can be hard to know what the issue is without having the documentation for the Modbus slave. I really need to see that before I can make any conclusions.

Good Afternoon Kyle,

I have called that number, but after waiting on hold for a while, I was forwarded and placed into voice mail.

I left a message with my contact number, but have not received a call back as yet.

The Slave is a basic ASCII device, not Modbus. That is why I am using the Generic Data Configuration.

I have attached the Manual for the Labeler.

I have also attached the Current Configuration for the Serial Linking Device.

I am currently working remotely, so for the testing phase of this project, We are only connecting to a terminal to emulate any ASCI data that may be sent.

The PLC program simply takes the characters from the input buffer and, converts to either a string or a DINT value and displays it on and HMI.

I am able to send the command string out through the Serial Linking Device to the terminal.

The current issue is that the data from the terminal is not making it from the Consume Transaction to the process tags.

The only character I see in the PLC Tags is the 16#0D (Carriage Return), but the full string is shown in the Rx Buffer in the log.

I have tried many configuration iterations, but the result is pretty much the same with minor variations.

I am fairly certain this is a simple error on my part, but it is just king my but.


CP300_EN2SER.cfg (16 KB)

ASCIICommsProtocol_v30.pdf (1.53 MB)