EN2SE-R to RFID reader

Trying to configure an EN2SE-R connected to an RFID reader over RS232 so that the value from a 16 character tag transponder shows up on Studio 5000 when swiped on an antenna.

Currently I have managed to get something on Studio 5000, but the value isn’t constant and frequently jumps around. When I log I get this

which is totally different from the value I get in studio 5000

so I know I don’t have it set up right somehow.

I currently have it set up in generic data mode and have been playing around with different stuff but nothing has worked so far.


Based of the ASCII in the logs, are you expecting the field to be “1234567”? If so, iin Studio you have set to a DINT value. THe translation between the Hex from the RX into an INT could be causing that issue.

What values are you expecting?

1 Like

Hi Kevin,

Thanks for getting back to me mate

Yeah, I’m assuming the tag has the value 1234567, will get back to you on that because the shift electricians have the tool to read the thing and I can’t get a hold of them.

How would I go about fixing this translation problem? I can’t send you the config file because IT has the laptops on lockdown but maybe these photos would help.


Yeah so the tag value is 0000000001234567, or that’s what the reader says at least as well as the log.


So you will need to update the data type in Studio5000. You will need to set it to take the data and convert it to ASCII. The gateway itself is getting the proper data, and transmitting it to Studio5000. The issue is that Studio5000 is converting it to the wrong data type.

1 Like

Hi Kevin,

Had a go at doing that but haven’t got anywhere. Changed the style of the DINT and it just shows as seen below

the DTOS instruction didn’t do much it just changed the data type to a string.

How would I go about converting it like you suggest?


Hello Nick,

I would take all the data as SINTs and convert each SINT to ASCII. Once the conversion is complete, you can put them to whatever variable/value you like.

1 Like

Aha, thank you Kevin that worked

Posting photos of what made it work for me for anybody else with this problem

Excellent. I am glad everything is working now. I am marking this topic as solved.

1 Like