Error Message in eCatcher

Computer locked up while installing software update. Now when launching eCatcher I receive the message:

The Windows Talk2M VPN Service cannot be found. Please check in the control panel if it is running or restart your computer.

The Talk2M-eCatcher adapter shows up in my network connections and I can connect to the eWon unit both through the eCatcher mobile app and the web app.

What can be done to get the VPN service to be found by the eCatcher software?

Hi @fulloutshr3d,

Which version of eCatcher do you have installed? Also could you try and uninstall the current version and install the most recent version of eCatcher?


Can you try and restart your PC and if that doesn’t work try and run the connection checker?

can I try and take a look at this over TeamViewer?

Good Morning Tim,

[TeamViewer Info Redacted]

Hi Jason,

Can you try to manually delete the Tap adapter and re-add the tap adapter?

The files should be found here:
C:\Program Files (x86)\eCatcher-Talk2M\Talk2mVpnService\drivers

Run the Removetap as administrator, then the adtap as administrator, then run the renametap.vbs file


Good Afternoon Tim,

I ran deltapall.bat, addtap.bat and rename.vbs and still get the same error message on my screen when launching eCatcher.

Hi Jason,

If you are still receiving the error it is likely the TAP adapter files did not get installed correctly witht eh rest of eCatcher. If you follow the directions in this post you can manually install the adapter then rename it to Talk2m-eCatcher

Good Evening,

I actually tried all of those things last night before I filed the ticket, with no luck. I will try again this evening.

Thank you,
Jason Crispen

Hi Jason,

Just to make sure, you were following this part of the ticket right? image

Good Morning,

Yes I tried that method again last night from the hotel and the message still popped up in eCatcher and it was unable to connect.

Thank you,
Jason Crispen

Can you try and run the deltapal to delete the tap adapter and then install the tap adapter from this link and rename it to “Talk2m-eCatcher” and see if that fixes it?

The NSIS file from this link

I was able to get this working again by uninstalling McAfee. Its firewall was creating the issue.

1 Like

Thanks @fulloutshr3d,

I’ll ask if other people can try that out as a solution