Ethernet communication problem with AB7072

I downloaded a configuration into this anybus AB7072 from another duplicate line that is working. I only changed the IP address. I went through the set-up for Logix 5000 PLC. I then tried to run HMS IP Config while online with the logix 5000 and plugged into the Anybus, but it doesn’t find any devices. I checked the settings for IP Config (v4.3) and it is set to scan all network interface controllers. Not sure what I’m missing…
Anybus status lights
1 flashing green
2 flashing green
3 off
4 flashing green quickly
5 solid green
6 flashing green

You should be changing the IP address using Anybus Configuration Manager, not IPConfig. The IP Address in the configuration will override an IP set by IPConfig.

The IP was changed in the Anybus Configuration Manager. I did that right after I downloaded the configuration that was working on the other line. I opened IP config and it doesn’t see any devices though. I was able to ping both IP address (PLC and Anybus) from my laptop.

It could be a routing issue on the PC, like another network adapter is using the same subnet, so the traffic is going out that port.

What I don’t understand is, why do you need IPConfig if you already set the IP address and you were able to ping it?

In regards to the IPConfig, I thought maybe that did something else in addition to putting in the IP address, but anyway, I do have the IP address in it. I can ping it. I did also unplug it and tried to ping that address again to ensure I didn’t have any collisions. All of our production equipment is on the same subnet ( I did compare the anybus properties screen within logix 5000. The status for the one that works says running for about 1-1/2 min, then faults, then says running again, continuously. The ones that don’t work. say connecting for about 5 sec and then fault, then connecting again for about 5 sec, continuously. The fault I’m getting out of the logix 5000 is: Code 16#0204 Connection Request Error: Connection request timed out.

Are these connected directly to the PLC or to an ETN card? If these really are identical setups on the AB7072 than it’s most likely a difference in the PLC, such as the firmware. I have seen issues like this before when ETN cards had old firmware.

If you could get a packet capture of the traffic between the two we’d be able to see exactly what’s going on.

They are going through an Ethernet card in the logix 5000 chassis. The lines that aren’t working are using a discontinued card whereas the one that is working is using a Ethernet card that is still supported. I can check into that.

When you say a packet capture, are you talking from the Anybus logging feature?

Do you know the model of the ethernet cards? It’s been a while, but I remember specific ones with certain firmware having an issue like this.

By packet capture, I mean using Wireshark software on the PC to capture the traffic between the AB7072 and the PLC. This would involve using a managed switch to mirror traffic on a port and capturing the packets. It won’t be necessary if we can fix the issue with a firmware update though.

These are the differences in ethernet cards


The issue was with the older versions of the ENBT cards (fw rev 4 and older) and similar. The encapsulation inactivity timeout feature in newer gateways can cause periodic drop outs with these cards that do not have updated firmware.

Ok, so you don’t think it’s the ethernet cards then… How do we do the wireshark plan?

To get the packet capture you will need a managed switch or hub (hubs are hard to find these days). On a managed switch, you would plug in the Anybus and the PLC, and in the switch settings, set one of the ports to mirror to another port. (A hub automatically forwards all traffic to all ports so you wouldn’t need to configure it if you could find one.)

For example, the PLC in Port 1, Anybus in Port 2, and PC in Port 3 and Mirror Port 2 to Port 3. This way, the PC can see all the traffic between the PLC and the Anybus.

Next you would run the Wireshark software and select the network adapter for your PCs Ethernet port. This will start to capture packets. Let it run for a minute or so and save the .pcap file. Send me the file and I will review it.

I guess it’s still possible that it could be the encapsulation timeout, but it’s unlikely. If you want to try to disable it, you can follow these instructions: