Ethernet/IP to can gateway


#1

Hello, I am using in one of our customers application a 7306 X Gateway ethernet/ip to CAN converter.

Everything seems fine from the ethernet/ip side, but we are unable to get CAN communicating.

our customer uses a roboteq controller that runs on CanOPEN, we set the same baudrate and already checked the nodes, we’ve got no error into the gateway, all lights blink green.

the roboteq controllers, broadcast messages thru the bus, the other roboteq controllers can listen and are working fine, but anybus converter could not listen the network.

I’ve tried to use Can communicator and Anybus Configuration Manager X-Gateway.

with both I can connect to the controller, but was unable to upload parameters or listen to the network. normally gives timeout error (already tried to use hyperterminal, but doesnt worked)

I don’t know how to proceed to establish a connection to the can side. and we don’t have a Can to usb converter. any suggestions?

regards

Rodrigo


#2

Hi Rodrigo,

You will want to look closer at the LEDs as green does not always indicate everything is OK:

What software are you using to configure the CAN bus? Are you configuring the Anybus X-gateway as a slave device?

Please reference the Device page and the
User Manual for instructions on how to configure this device.

Kyle


#4

Hi Kyle

I am currently using the Anybus Configuration Manager X-Gateway,

But I’ve also tried the

Anybus Configuration Manager - CANopen Setup 1.5.0.0.exe

ACM Communicator CAN Setup 1.7.1.1

With no luck in any of these.

We have also an USB/CAN cable, we are able to listen to all nodes on the network

Except for the anybus.

Regards,


#5

#6

#7

What else is on the CAN bus? Is there another Master?


#8

There are no other masters. There are 2 slaves. But i have taken those off the bus and i get the same results.

Dr. Elmer Lee
Head of Exploration
Conceptual Innovations

elmerlee@conceptual-innovations.com
734 678 2976


#9

#10

Two roboteq controllers (motion)

They talk in CanOpen with broadcast to the whole network.

But we tried also to connect directly with the usb/can, but with no luck.

regards


#12

Hi Rodrigo,

I think we talked to Elmer on the phone about this one and he is going to get the IXXAT USB-to-CAN v2 so he can configure the device becaues the software isn’t recognizing the other USB to CAN adapter.

Thanks,

Kyle


#13

He talked with me about that

tks