Ewon can't connect to the internet

I’m having issues connecting my Cosy 131 ETH to the internet using the ethernet.

I currently have it configured with static connection using information provided by the factory’s IT department. The LAN and WAN connections work but connecting the Cosy 131 to the internet still results in a failure using the device wizard.

I also connected the ethernet to my computer to verify network connections which worked then I used the talk2M connection checker to verify internet connections successfully. I’ve tried resetting the device several times, upgraded the firmware, whitelisted the server sites and successfully pinged those servers from my computer.

I’ve attached the log files and would greatly appreciate it if I can find a solution to this problem.Backup.etar.gz (13.5 KB)

How long is the cable run to the WAN port?

I have two Ethernet cables each about 8ft in length joined together

The errors messages are indicating it’s an issue with the cable, possibly interference (EMI). I would recommend replacing the cables with shielded CAT6 cable.

Were you able to resolve this issue?

I’m still waiting for updates from the client’s technicians.

OK, thanks for the update. Please let me know when you hear back.

Hi Kyle,
The technicians have changed the ethernet cable and we tried running the internet wizard but received some errors again. I’ve attached the error report.

It’s still giving the same error in the logs, indicating a cable problem. What is the total length of cable to the switch?

Have they tried connecting directly to the switch with a short patch cable to see if the errors go away?

Another thing that might correct the problem is adding a small unmanaged switch at the end of the cable run and plugging the cable and the Ewon into that switch.

I’ve forwarded your response to them and I’m waiting for their reply.

OK thank you.

Problem has been fixed. We found out that the network connection works when we switched from UDP to TCP.

That’s strange as that setting is only for the VPN and doesn’t have any effect on the Internet Wizard. The Internet Wizard already uses TCP.

Anyway - Glad it’s fixed!

Hi Kilanga - seems like we are having the same issue in our warehouse - can you share where you performed the switch from UDP to TCP to fix this issue?


1 Like