Ewon Cosy 131 - Cannot online monitor S71200 PLC


I have opened a support request (202104-28758), which was has not had a reply for quite some time now, and called the support phone number, and the message I have left has not be returned. My support access also was inconveniently removed after 20 minutes of having an account registered, meaning I could not respond to the agent who had originally replied, until the ‘webmaster’ granted me access again this morning.

I have a critical issue which is stopping me from giving my customer support, which has extended their downtime. Below are two of the messages I sent to the support ticket

------Original ticket description-------

I’ve been trying to use a ewon to communicate with a S71200 PLC. This device is brand new, only installed yesterday. The ewon is a COSY 131-4G EU, which is operating in the UAE. I was advised by my supplier to go for the EU version for Dubai. However it is currently using an ethernet connection (42mbps down, 15mbps up), as part of our troubleshooting process, so the modem can be ignored.

I can ping the PLC (200ms) as well as download to the PLC

I am able to communicate with and monitor the variable speed drives in TIA portal V16, but cannot go online with the PLC. It will appear as though it may connect, but then shows a question mark for 30 seconds and then says ‘Operation aborted.’. I can also communicate with the plant pc via RDP.

I have updated the firmware on the cosy, updated my copy of eCatcher and tried to use another PC but cannot connect to the PLC using eCatcher.

I have tried forcing TCP and not forcing TCP (in the talk2m wizard). Neither seems to make any difference.

To test if the issue was with the PLC, I installed teamviewer VPN to both my PC and the plant PC and can make a online connection to the PLC via Teamviewer VPN.

----My reply which has been unanswered----

Apologies for delay, the support system locked me out for some reason and I had to wait until the webmaster fixed the issue. I’ve numbered the screen shots to give an idea of the order of sequence.

  1. I can scan the network and see the connected devices (note the drives were powered down in this screenshot, but normally appear.)
  2. I can see the PLC online.
  3. It appears to show as connected, but with question mark.
  4. After 30 seconds, the connection aborts.

Other things that I have tried since yesterday, with no change.

We have replaced the PLC.
We have tried 2 seperate ewons, both with same issue.
We can connect to other ewons in our system, and successfully connect to their respective PLCs.
We created a new temporary Talk2m account and added the ewon to that.
We have tried both ewons with sim installed to ewon, and also the sim installed in external 4G router, with ethernet connection to the ewon.

Also to remind you, we can:

Use teamviewer vpn to go online with the PLC.
Using ewon/talk2m I can download to the PLC, so long as I dont attempt to go online.
Using ewon/talk2m I can go online and monitor the drives, as well as use RDP to connect to plant pc.

Prompt support would be appreciated, thank you.

Hello Josh,

I just wanted to leave a note here, it looks like you are already working with our Jean-Yves out colleague with ewon on this issue. He will be your best contact for this issue.