Ewon Cosy 131 WiFi Won't Connect - Stuck on Internet Wizard

We are having an issue when trying to connect Ewon Cosy 131 WiFi device. The ewon was working before and able to remote in and setup the devices with no issues but recently we are required to change the network that is connected and are running into problems when trying to connect it to WiFi.

When we try and run the internet wizard, it ends up getting stuck when testing the connection and the test does not timeout or provide any feedback. We have let the internet connection test run for more than 5 minutes and no timeout or update has occurred during the network test. We tried connecting a different Ewon Cosy 131 WiFi on a different identical machine with the same network and that worked with no issues. Also when trying to run a system wizard as well it seems to get hung up as well on the last part such as the system wizard. Exiting out of the internet test wizard requires us to power cycle the ewon since when we try and run it again a popup comes up saying “Wizard in progress” which I assume is happening because the initial wizard being ran is not completed or timed out.


Hi @Mbou,

What type of WiFi system are you trying to connect to (for example, an enterprise Cisco system with multiple Access Points, or a small wireless router, like a NETGEAR)?

Can you please use eBuddy to create a backup of the Ewon and select “Include Support Files” so that we can take a look at the logs and settings?

Thank you,


Hello Kyle,

We tried using a hotspot on a mobile phone to test out if it’s an issue with the network or something else. We had it setup with an enterprise system with multiple access points initially though and were using that before.

I don’t know if I’ll be able to grab a backup with support files from ebuddy, would grabbing the log from the web interface work as well?

It is much more helpful to us if you can get the backup with the support files using eBuddy. You can do this remotely through eCatcher or connected locally. However, any logs or screenshots are better than nothing, so I’ll take whatever you can get!

Also, just to clarify, you cannot connect to the enterprise WiFi or the mobile phone hotspot?

We are having trouble connecting to both the enterprise WiFi and the mobile phone hotspot, the internet wizard when setting the device network hangs up (the setup is from the ip address/webpage for the ewon device). We also tried running a hardwired connection to ethernet a while back with no success, but that seems to be related to the way the customers local network is configured, which I have no control of. We are not able to connect through eCatcher since there is no internet or network connected to the ewon. The model used is WiFi so gsm/sim card is not used.

Where we are getting stuck is at a screen similar to the image below, but the current operation is stuck at establishing WAN connection with the timer going passed the 5 minute mark (300+ seconds), results are not updated either and the network isn’t timing out. We set up the ewon to also be through DHCP and disabling the HTTP proxy and talk2m proxy before running the test.

The below screenshot is not from our ewon as I have no way of accessing it remotely, but just used an example as it’s similar to something I found online.

The ewon is currently out in the field at our customers facilities so it’s difficult for me to gain access to the physical device. I’m working with the customers to try and install ebuddy and to get the support files from the device.

Unfortunately, without the logs, all I can do is guess about what the problem is. Maybe there is an IP conflict (the LAN and WAN subnets are the same)? Maybe there is a setting blocking communication (like RTEnIPFwrd=0 and/or NATitf=0, they should be 1 and 3 respectively in the comcfg)?

You are also running very old firmware if you are seeing a screen like the one above. The current firmware is 14.5 and the user interface was updated in 13.0 and looks like this:

You can update the firmware using eBuddy.

Hi @Mbou,

In the logs we keep seeing this error:

1641317569	04/01/2022 17:32:49	pla-Cannot reach WIFI SSID  (NMagna)	pgdef-Cannot reach WIFI SSID 	wanmgt	79336	20172

Are you scanning for networks and selecting “NMagna” from the list or entering it manually (in the Internet Wizard)?

Actually we aren’t using that network anymore. That was the previous network we tried connecting to, we are selecting the new desired network from the drop down list and it appears with a few bars of signals.

Is it still not working after updating to v14.5? If not, please do a factory reset and try again.

1 Like

Thanks kyle!
Updating the firmware fixed the issue!

1 Like

Great! Glad to hear that!