Ewon Flexy 203 Locking up

I am having a strange issue with my Flexy203. I have tried updating to the latest firmware (14.5s0) and the issue persists.
Either of the two actions results in the Ewon locking up and rebooting itself:

  • Adding a tag
  • Attempting to change any value
    I should add, that data is read without issue from the device. My configuration is as follows:
    Siemens S7-400 CPU connected via Profibus to the built-in MPI port on the Ewon.
    Does anyone know of what could cause this behavior to suddenly start after the unit has been in service and working previously for a couple of months?

I haven’t seen this happen before.

Can you please use eBuddy to create a backup and make sure to check “Include Support Files”?

Please find the requested file attached.

Please try this-

Go to Setup > System > Storage > Edit SYSTEM cfg and search for HTTP_REQTO. Change the value to 150 and make sure to click Save.

Reboot the Ewon and see if it continues to happen.

Kyle, Hello thanks for the assistance. I just tried to change the setting to 150, but that too caused the device to lockup. Perhaps I will need to make a backup with eBuddy, change the setting in the file, then perform a restore?

Yes, you could do that if it keeps happening and keeps you from changing the setting. All you would have to do is create a file called config.txt with:


And send via FTP and replace current config.txt.


I tried that and the unit locked up. I tried it by editing hte value in the config.txt in a backup, and restoring the backup. The restore failed and the unit locked up again and reset. I attempted a second time and was successful. I did notice the second time that while the IP was not affected I had to use the default username and password to restore (adm adm). I tried to change a value this morning and I am still having the same issue.

I also verified that the setting is indeed in place.

How long was this running fine before this problem started happening?

Have you added any new tags recently?

Any other changes preceding this issue?

Just to clarify, it looks like you aren’t using the WAN interface and aren’t using the device for remote access, just for the s7 IO server and ViewON? Can you give me a little more information about how you are using the Flexy?

Are you using an SD card?

Are you sending emails for alarms or reports or anything like that?


No, Last week I found that the Ewon was no longer communicating with the S7 CPU after about 6 weeks of being in service. I had installed it and performed the initial configuration and added the tags you see in the config. The only recent change before this started happening was the addition of two static routes and 128.1/16 so that our device was accessible through the firewall that controls access from our IT network to our factory network. For security reasons we can no longer use the WAN interface card and connect it directly to our IT network, all traffic must pass through the Checkpoint Firewall and I found that adding these static routes allowed the Ewon to respond to traffic from the IT Network. I do not believe I observed this behavior before then.

I checked with the Ewon engineers and they think this is caused by the s7 IO server poll rate being too fast. I see it’s set to 125 ms which is most likely not achieved by the system. The Ewon takes much longer to poll all his tags. They said you should increase the poll rate to 3 sec (to be sure).

The only way to change the config is to change the memory settings (which erases the config).
So, first make a backup, change the memory settings (change ‘memorg’ in comcfg.txt from 1 to 2, for example) and reboot (you lose tags, ioserver, etc.), set the poll rate to 3 sec in the backup (Use 7Zip and notepad for example) and restore the backup (twice as you 'll restore another memory config which will erase your sys config again).


I am just seeing this, I have been working on another project. I will try that now and let you know the result. What is the maximum achievable polling rate? Does it vary depending upon the number of tags being polled? Is there any way to monitor the polling time vs cycle time of the main process in the Ewon? Thank you

Yes, it will depend on the number of tags. That’s why I would start with a higher number like 3 seconds and go down from there.

There is no direct way to do this. You could use a packet capture (Wireshark) for ISOTCP or could check the serial debug logs for MPI in order to figure it out. Keep in mind, it also depends on what the PLC is capable of. If it has a big program, it will allocate less time to communications. We have seen a big difference between an empty and loaded PLC (like 500ms to 2500ms) with the same tag list.


I have performed the procedure. Once I have time I will also test adding some tags and I will let you know the results.

Best Regards,

Nate Miller

OK great - thanks for the update.


I am now able to add additional tags. Is there a way to determine the fastest update time for a given amount of tags?

Is this a serial or ethernet connection.

The connection to the CPU from the Ewon is via the embedded MPI port at 12Mbps. The connection to the Ewon for the webserver and Viewon webserver is over ethernet.

You can try enabling serial debug:


This should give you time stamps to help determine how quick the communication occurs. However, running the debug itself can affects performance somewhat.


Do I need to have a serial expansion card installed on the Flexy 203 in order to use the serial debugging function?