Ewon flexy 205 OPC UA Server & Client


I know ewon Flexy as VPN, but it’s the first time, that I use it as OPC UA, I’m Able to read data from PLC to Flexy, the problem :
how I can test the connection to OPC UA server?
what’s information that I have to give client that have kepware server to get access to tags that I create in ewon flexy?

Thank you

Publishing EWON Tags for OPC UA

Here is a link to docs:

I found this example for Kepware v5.2:


You could also publish modbus TCP and have kepware server read those registers to test.



I create a tag that I receive from PLC ro share with OPC UA
name of tag: LogTag_Integer


did I have to change something , see please the part in yellow
I enable OPC uA IO server
but when I create a Channel in kapeserver
to add tag in kepserverEX, I use expression: ns=3;s=Channel1.Olymel2019.LogTag_Integer
Using OPC Quick client:
it’ s seems that connection is good but the tag cannot be read
Can you please help
Thank you


Did you tell the flexy which group of tags to publish?


Hi, thanks for your support but I have that selected in ewon


I review the configuration of KepServerEX 6

those tags that I try to connect to

  • LogTag_Integer: Log tag Integer for Counter
  • LogTag_bool1: Log Tag Boolean flash every 2000ms

the syntaxe of tag in kepwareserver is the following:

maybe the syntexe not correct ?

If I try tag generation , I get error



I receive your email form Simon-Julien Elie, as I’m short in time to resolve the problem.

We have ewon Flexy with firmware 13.0s0

I create tags that pull date from PLC to ewon, this part work perfectly.


Have you checked all of the documentation for the OPC UA server? I am not very familiar with it, but it seems there is some kind of configuration missing on that side.

You said the connection is good, but are you sure? can you ping flexy from OPC UA server? Is there a firewall in between? Is that port open?

There was an error in the software for the Data Logger Plug-in which says “data source not found and driver name not specified”. Is there a driver that you need to set up?

Is this working with other devices, other than the Flexy?


To make the troubleshooting easy

I Use the OPC UA technology sample

As you can see ,I’m able to see the sever , so the port not blocked by the firewall.

When I use the next step to open a session:

I use the same use and password that I create in OPC Ua IO server settings

The result i get bad use access

Bonne Journée / Best Regards

Samir Hamroun, M. Sc. A. / M.A.Sc.

programmeur PLC R&D / PLC R&D programmer • Phone: +1 418 885 4493


Make sure the OPC UA client is logging in with an eWON user for which the right “Force
Outputs” has been granted.


Thanks , really that’s the missing information that I have to create user that match with OPC UA.
I hope this information be added in help.
Thanks again for your help,


Great! Glad it’s working for you now. It can be easy to overlook in the manual, but now it will be on the discussion board.

Thank you,


Hi Guys!

My application is working fine now but I have last Question :

Did we have a way to connect to UPC UA ewon without to install ecatcher in client side?

I would like to give the client just the following information:

opc.tcp://server[:port] (port 4840 used when not specified)



Without activing ecatcher the UPC UA stop working. Did you have any proposition

Thank you

Bonne Journée / Best Regards

Samir Hamroun, M. Sc. A. / M.A.Sc.

programmeur PLC R&D / PLC R&D programmer • Phone: +1 418 885 4493


This depends on how your network is setup. I assume you must be connecting to the Flexy through the VPN currently. If you connect locally you won’t need the VPN and eCatcher. Is the Flexy on the same physical network as your OPC UA server or can it be? What does the network look like?


Hi Kyle,

The client will use the wan connection to get access to OPC UA Server from ewon Flexy 205 as showed below


Endpoint Url:

opc.tcp://wan adress:4840





The idea was in drawing that i find in ewon documentation, it’s was no comment that I need to have an active ecatcher to make the UPC UA work,?

the good to give client access to tags in UPC UA by WAN connection without give the client access to our LAN network, that why I choose ewon flexy 205, but I never know that ecatcher is require to make that working

I hope with this description, you know my need and you can get me the right answer or suggestion

Thank you

Bonne Journée / Best Regards


Hi Samir,

I need more information on the networks involved. Which devices are on the same network and which are on separate networks. The drawings show the Flexy and PLC on one network connected to the Client and SCADA on another network via VPN connection. Isn’t there another OPC UA server? Which netowrk is that on?



Hi Kyle!

The PLC and ewon are in the same local network

But the client Scada are in another network and will use WAN to connect to the UPC UA trough internet.

Let me know if that clarify the situation?


Bonne Journée / Best Regards


Hi Samir,

In order to connect the 2 remote networks securely over the public internet, you will need to use a VPN. You can use eCatcher or another VPN, but we can only support our own VPN. We can’t guarantee another company’s VPN is going to work as we don’t have control over that. You can also use the M2Web API for transmitting data securely over the internet. Of course, that will be more complicated to set up and support.




When i try to import tags from ewon flexy to kepware, it shows error.
Could i know how to solve this issue?

Thank you!


Have you made sure that the OPC UA client is logging in with an eWON user for which the right “Force Outputs” has been granted?