Ewon flexy 205 OPC UA Server & Client


#23

Hi,
yes, the force output access right has been granted, and i had imported the kepware server and client cert to ewon but it still doesn’t work.


#24

Where (on what network) is the OPC UA Server located? Can you ping the ewon 192.168.3.5 or connect to port 4841 from the network (nc -v 192.168.3.5 4841)?

What type of authentication are you using? (Password or certificate?)

There are many reasons that you may be getting this error, so any additional information you can provide would help.


#25

Hi Kyle,
I plan to use Ewon Flexy as my OPC UA Server and Kepware as my OPC UA Client.
In flexy, my ip address is 192.168.3.5 and i set my port to 4841. In the OPC Connection, i set it as anonymous login.

In my Kepware, i created an OPC UA Client, and i set the UA Server URL as image below.


In Authentication, i leave it blank to ensure anonymous to login.

However, in OPCUA Configuration page, i can’t inserted my flexy ip address in server endpoint. There are only two servers endpoints as image below.
image

i had trusted ewon certificate in Kepware as image below although anonymous login does not need to do this.
image

I can read the tags from kepware to ewon flexy using IOSERVER OPC UA (i just type kepware server endpoint url in ewon opcua ioserver), but i can’t read the tags from flexy to kepware. Does all the information above helps?

Thank you.


#26

You need to make sure that the authentication settings are matching up in both the Flexy and the Kepware software. Something is not set up properly. Generally we don’t recommend using anonymous connections, but if you really want to you will need to make sure both sides support it. I’m not sure that Kepware allows it, so you may want to consider using a username/password or certificate.

You can try changing these settings as well:
Device properties > Subscription > Update Mode = Poll
Device properties > Subscription > Registered Read/Writes = Disabled


#27

Hi Kyle,
It works. Thank you very much.:blush: