eWON FLexy rebooting "Reboot reason: Watchdog in process (biditr)"

Hi I am having issues with one of my eWONs rebooting. I can see in the logs various records regarding connection issues but do not have enough knowledge to troubleshoot.
I have added a backup of the ewon with support files.
I noticed a reboot had happened prior to 1545h 23/06.
When I am connected to this ewon it is quite common for the connection to drop out and reconnect after a few minutes.
Please assist as the ewon rebooting is causing issues with the machine running.

Backup is too large.



Can you try disabling the script? The Biditr errors are generally caused by communication between the ewon device and our Talk2m servers. I do see a FTP Push in your script, that could be the cause for the issue.

Hi Kevin,

I have disabled the script but it doesn’t appear to have slowed down any of the errors.
Can you explain the meaning of some of these errors?
“httpc-http request error” esyncitf
“esock-Socket function returned error” esyncitf
“httpc-http connect error” esyncitf
“esock-Get default gateway failed” ablsrv
“t2m-DNS failure, using static Talk2M access server” openvpn

Are you running esync on the Flexy? If not, can you disable it? If it’s needed, i would check the settings for the eSync acces.

The Get default Gateway failed on the ablogix server. Do you have a gateway set up on the PLC? It looks to be an issue with it connecting to the Flexy.

Hi Kevin,

I found the default gateway on the PLC is not set to the ewon so I have set that.

esync was used in the past but now it all goes through the Talk2M API. How can I disable esync?

Within the Data managment section, there is a drop down menu on the top right hand side. Select the entry for eSynch.

Hi Kevin,

I have the Talk2MAPI selected in the data management and it works as expected. I tried selecting esync and deleting all the fields and clicking update. Then selecting none then back to Talk2M API.
the esync error logs are still occurring a lot.
I cannot see why esync would be enabled or how to disable it? Or are the esync logs referencing the Talk2MAPI?

The esync logs will refernce the Talk2m API logs as well.

The BASIC ide is triggering the API and Esync. If the device goes offline, then it will cause esync errors when it trys to run the code.

Any update on this?

The Basic IDE has been turned off for over a week now and I am still getting error logs.
Best I can understand is that the WAN connection appears to either drop or not be able to reach some server? talk2M server and also the NTP server?
Reboot reason: Watchdog in process (pppl)
esock-Get default gateway failed
uact-NTP time synchronization failed (Server: pool.ntp.org) - I can only assume this is due to no connection?
esock-WAN connect on demand failed
wanmgt-No route to connect to (xxx.xxx.xxx.xxx)

Hello Barryt,

Reviewing the backup again, i do notice that your gsm levels for the Cellular connection are very low. Can you relocate the unit to a better area with signal? or get an extended antenna?

Hi Kevin,

I am confused about this cause I have never seen the GSM levels bellow 4 bars on the flexy interface.
It doesn’t have an external antenna but we can add one to test if that helps.

Using the bar count is not the most accurate method to determine signal quality.

I advise going to Setup->System->Communication->Internet->Modem Interface. Here you can get the GSM level of the cellular connection. We our system requires a GSM level of atleast 18 for a solid connection. Anything below that can cause issues.

Any update on this issue?

Hi Kevin,

I have ordered an external antenna.
After installation I will monitor for behavior improvement and update.

Has there been any update on this issue?

The new antenna has been installed at site.

Still changing between 14 and 21. But there is now a connection time of 7 days solid so looks good.

Just for reference the ewon was located inside a stainless steel cabinet with the standard antenna previously which did work but had alot of reboots due to lost server.

Cheers for the help!


I am glad the connection has been maintained.