EWON not reachable since ecatcher update from 6.9.0 to 6.10.0

Hello support,

I do have a weird situation in my group of EWON users. At the beginning of this year we updated the eCatcher from 6.9.0 to 6.10.0. Since this update we have issues with the conneciton to the Ewons.
It is randomly changing to another person/laptop in the office.

To explain this better:
We have a “pro Account” with about 5 users randomly using max. 3 connections at the same time.
We are all able to enter the account and we can all etablish a VPN tunnel to our EWONS without any error message, but only one of us is able to ping the PLC and HMIs on the other side of the connection. This is a real problem as this is changing randomly throughout the day.
This is what we already found out:

1.) First user of the day can work without any issue
2.) All others have the same issue → VPN tunnel seems to be OK but nothing can be really reach. Even not the webserver of the ewon itself.
3.) Talk2Mconnection checker says that erverything seems to be ok
4.) We have checked the Ewon-logfile and found out that the added route has not been deleted after the first connection has been cancled → so each new connection is adding a second route in the routing table which is for sure not correct too.
5.) We have tested this with several different internet connections and with/without firewalls. → same thing
6.) Antivirus software has also been deactivated fully
7.) we have updated the driver for the TAP adapter → this has occured another issue
8.) we have changed back to 6.9.0 → it has worked for one connection but now it is even not working anymore with 6.9.0

Now i am not able to support our customers anymore which is really critical as we have about 400 EWONs out there…
Honestly i am not even sure if the fault is on your side but maybe you have any other idea where i can look at.

Thanks in advance.


Hi @Mario_1234,

I have not heard of any issues like this with eCatcher 6.10. As this sounds like a critical issue, I would recommend that you create a support case at https://support.hms-networks.com so this can be escalated to the Ewon team.

Can you send a screenshot from a problem PC showing eCatcher connected to the Ewon and the command prompt with the results of ‘route print -4’?

Can you also send the logs from eCatcher? (Go to Settings > System Logs)

Best Regards,


hi @kyle_HMS,
Right now we think that it is an internal issue in our company network!
Thanks for your support.

OK thank you for the update. We had another customer report a similar issue just a few minutes ago, so I was wondering if there was some kind of problem with the update.

Actually i uninstall the ecather and install any other version then the connection is working for the rest of the day. next day same thing…is this similar to the other customer issue? Then it might need to be double checked on your side too :wink:

Not exactly… Ecatcher connects to different ewons, but devices cannot be reached

They just can’t reach the LAN devices at all. In your case it’s strange that you can reach them on one day, but cannot on the next day.

Have you gone through all of the troubleshooting steps in this article and also made sure to reboot PC after installing eCatcher?
Unable to connect to LAN Device.pdf (753.0 KB)

There was another customer experiencing a similar issue and here’s how he solved it:

Hi Kyle,

Thanks for this suggestion. It truly solved the issue on our side too.
Does anybody right now know what is the reason for this?

No, I’m still waiting for an explanation from the Ewon engineers. I will let you know as soon as I have some more information.

1 Like