eWON - Offline issues


#1

Hello,

I have 6 ewon Flexy205’s out in the field for a customer (account name “engineeredlubrication”) that frequently show offline status. These are all connected via ATT cell networks. When they do pop up online, I can connect to them, pull up the ewon web page and see the cell network is either full strength or at worst, one bar below full strength.

As an example, the “Patapsco” ewon on the account showed offline most of the day yesterday and I was unable to connect. This morning It shows it online and I can connect up to it and view the logs. It shows several offline and online entries from yesterday, but the times it says it was online, I was still unable to access it.

Attached is a backup file with support info (for “Patapsco”) I just downloaded this morning from there. Can you give me some pointers on things to look for to solve this intermittent connectivity issue?

Regards,

Ryan Nicholson

MOVED TO STAFF NOTE (197 KB)


#5

Hi Richard,

Can you upgrade to firmware 13.2 and see if that resolves this issue?


#7

I don’t have physical access to any of these eWON’s out in the field. I can remotely upgrade the firmware without wiping my t2m connectivity and configuration?

Ryan Nicholson


#8

#9

I generally wouldn’t recommend updating devices remotely just in case the device goes offline. But you don’t need to worry about losing configuration settings just from a firmware update


#11

I was able to update the firmware to the latest but am still having issues with my Flexy205 disconnecting from VPN and requiring a reboot to force it to reconnect. When my customer visits the remote site to reboot, we have a green Cell status and then all 3 cell signal strength LEDs are illiuminated but no “T2M” light. After a reboot (sometimes several) the T2M light will illuminate and the eWON will show backup up online in eCatcher.

During the times I can actually remotely connect to the eWON, the cell signal strength is full (as indicated by the dashboard on the ewon home page). I’ve changed the “Max Outgoing Call Duration” to 0 so it doesn’t try and hang up. That seemed to keep it alive longer, but eventually will drop the T2M and go offline until reboot.


#12

MOVED TO STAFF NOTE (173 KB)
here’s my latest backup file for review


#14

Please try this:

Go into the COMcfg (Setup > System > Storage > Edit COM cfg) and change the following settings:

VPNAlive = 30
EthDns1 = 208.67.222.222
EthDns2 = 8.8.8.8

Then go into Edit SYSTEM config (or config.txt) and change:

HTTP_REQTO = 180

Hopefully this improves performance, but there were some instances where the eWON was having trouble getting back on the cellular network. Is it possible it is switching between different towers and one is roaming, or an unsupported carrier? Who is the cellular provider?

Kyle


#15

I will try this when I can get someone out to the remote site and reboot the ewon.

The carrier is AT&T. The location is just outside of baltimore - I can’t say for sure that it’s not trying to roam, but I do know the AT&T coverage at this site is great.

I know sometimes you need to change the UDP vs TCP mode, would this have any effect on the T2M dropping and not re-establishing?


#16

The ewon came back online Saturday afternoon, I was able to connect up, download a log file and then make those settings changes. 20 or 30 minutes after I applied those settings, it went back offline and now is offline as of now.

Carrier is AT&T and ewon dashboard shows full signal 4G connection.

MOVED TO STAFF NOTE (176 KB)


#18

If it comes back up, can you also change EthDnsAuto to 0? If it keeps happening after that, I think you should run the VPN/Talk2m wizard again.


#19

Can I run the VPN/Talk2m wizard remotely? I don’t have physical access to the device.


#20

I changed EthDnsAuto to 0 and still have had dropouts. I went ahead and re-ran the VPN/Talk2M wizard remotely as I figured it couldn’t make it much worse. The wizard completed successfully and stayed connected all night but dropped out again this morning and was off for 20 minutes or so before it came back. Looking at the log, I have lots of “esock-WAN connect on demand failed” and “eserial-Write failed (input/output error)” and numerous watchdog reboots. It looks like after the watchdog reboots several times, the system will eventually connect.


#21

I believe this is a faulty modem and you will have to send it back to your distributor for a replacement. They will need to know the ticket number, which is 20404.

I’m sorry for the inconvenience. Please let me know if you have any questions.

Kyle