Ewon user without Change Configuration is not prompt to enter credentials the second time it log to an ewon custom page using Talk2M


So I’ve been experiencing something similar to Insufficient Rights error on View IO screen and the solution found there does not seems to apply to my case.

Here the context:

  • Model : ewon Flexy 205
  • Firmware version: 13.3s0
  • A user “Client” was created with these rights (Tag Page allowed: All, User Directory allowed: All, Global user rights: [ViewIO checked, FTP Server access checked])
  • I set the User defined home page to an index.html custom page that I created
  • In this custom page, I send “export block descriptor” style command to get tags every second info Ex.

Steps to reproduce the behavior:

  1. Connect to Talk2M using an ecatcher user
  2. Connect to the ewon having the custom page
  3. Enter the “client” credential when prompted to
  4. Close the browser
  5. Open the browser
  6. Connect to Talk2M using an ecatcher user
  7. Connect to the ewon having the custom page

Result: The second time I access to the ewon custom page, there is no pop up to enter the ewon user credential. Also, the command that I send return an error 401 unauthorize access.

I noticed that if I gave access to the ewon user to the “Change Configuration” right, pop up to enter the credential would start to reappear everytime I would connect to the ewon custom page.

The problem is that I don’t want to give access to my client to configure the ewon. I just want him to connect to my custom page and at best have a read-only view of the ewon configuration.

Is there any quick fix to my problem?

Thanks for your time,


Thank you for the very thorough post.

Can you try updating the firmware to the latest version and testing again?

Hi Kevin,

I’ve updated the firmare to 14.0s02 (#1005) and the behavior described previously still occurs.

Anything else I could try?


I will need to investigate this issue a little more. I will follow up with you early next week with an update.

Hi Kevin,

In case it helps solving the case, I want to add that my custom web page is located in a subfolder of usr like this : “usr/dashboard/index.html”.

Also, here the unauthorized message received :

Access Error: Unauthorized

when trying to obtain  **/rcgi.bin/vows/readVars?_vars=SystemMode%2CLineState%2CResettableRuntimeHrs%2CResettableRuntimeMins%2CRuntimeHrs%2CRuntimeMins%2CActiveRecipe**

Access to this document requires a User ID

I want to add that I used Google Chrome Version 79.0.3945.130 (Official Build) (64-bit) for my test.

I tried the same steps described previously with Microsoft Edge 44.18362.449.0 and the prompt windows seems to reappear on the attempt beyond the first one. I notice tho that m2web is now connecting to us4 instead of us3 without the need of the right « Change configuration ».

I don’t know what you changed in the server / domain « us4 », but it seems to be working now.

So I’ve try Google Chrome again, and the prompt window seems to appear all the time now since the change of « us3 » to « us4 ».


Excellent, I apologize for the lack of responses. I was trying several different tests to replicate this issue.

I will mark this as solved for now, but let me know if it occurs again.

Hey Kevin,

Unfortunatly, it occured again today with the « us4 » domain / server.

Any clue of what it could be?


Hi Kevin,

I have not heard from you since the last time I post here.

Do you have any ideas of what could be happening?

I test it again yesterday and could only replicate it once.

But since the solution is not easy for our clients (we need to clear the cache), I would like to find a definitive solution and not hope to fix it for our clients everytime it occurs.

Thanks again for your time,


I performed several tests on this issue, and found once the log in occurs. Its cached as a success, which eliminates the further need to log in again. I will have to escalate this issue further and it will be up to development on how it is going to be addressed.

Hi Kevin,

Do you think there could be a workaround for this issue that I could try on my end other than giving the “Change Configuration” right temporarily?

Hi Kevin,

Today I was connected to my ewon using M2Web and an admin user and when I reconnected to the web page on the ewon, the pop up window to enter the credentials was gone and all of my
command “https://us5.m2web.talk2m.com/machinex/RDHT:57921/rcgi.bin/vows/readVars?_vars=LineState” was returning me an 401 Unauthorized status code.

Here’s the preview message :

Access Error: Unauthorized

when trying to obtain /rcgi.bin/vows/readVars?_vars=LineState

Access to this document requires a User ID

This admin user has the “Change Configuration” right:

I’m trying to provide you many info as possible in the hope that you will find a solution or a workaround soon.

Thanks again for your time and have a nice day,


There is no real way to modify the the code of the unit tto ensure log in occurs at every access of the page.

As for the error page above, did you try to go back in the history of webpage? Or was this navigating to the web page from the beginning?

As for the error page above, did you try to go back in the history of webpage? Or was this navigating to the web page from the beginning?

I’ve opened the “DevTools” (F12) within the google browser and it was a message I had in the Preview sub tab of the Network tab.