Failed to initialize ramloader

I’m setting up a ABCC-40 Starter kit M40 and cannot get it connected.
I have the unit connected via the USB cable that was provided, I have the selector switch set on position 1 which is what the manual says is for USB connectivity. I have the ID switch set to 1 and that’s the selection I make in the configuration of the comm profile in the software.
My device shows that HMS Development Board 2 is ok.
I get the “Failed to initialize ramloader” when I say ok to the transport provider setup.
Any help would be appreciated.

Could you please upload a screenshot of this? Does this happen when you are trying to run the Windows SDK? Do you have another ABCC module you can test this with?

For completeness I wanted to update this issue. If you run into this issue please contact HMS support at 312-829-0601 (for US customers) or visit to reach out to your local office.

I take this post again because I have the same problem when I try to update firmware to Compact Com C40 via USB. I have no problem via FTP. I use Starter Kit. There is a procedure to follow?
Thank’s in advance!

Hello @paolo,

This error will occur when a connection to the CompactCom is unsuccessful. Make sure the Compact com is fully connected, the dev board has external and the usb is connected and shows up as a device on the Pc. Make sure the transport provider is configured correctly with the HMS Development board 2 provider selected and the board id showing up in configure.

Thank’s for reply, Monday when I return at work I retry and I will post screenshot, but I’m sure that the conditions have been met.

This is my condition. After this I’m not able to continue

Hello @paolo.

It looks like the starter kit is getting detected. Do you have another CompactCom to test in the starter Kit?


Yes, I have tryed with many Compact Com C40 (Ethernet/IP and Profinet) but without success. Only the FTP is OK for me! :disappointed_relieved:

How are your dip switches set on the device? Try setting all 6 dipswitches to off if they are not already.

It is also worth double checking what version transport providers you are using. You should see the version installed in add remove programs. The latest version should be and can be downloaded here under software.

Unfortunately I have tried this too, including software updating :pensive:

Hi Paolo,

Do you have access to a another PC to test with or a second starter kit? You might also want to submit your request over to This will allow us to pull in more people if needed.


Also with another PC it not run! I think I have to open a ticket to support. Thank’s.

Thank’s Deryck, I do not have another Starter Kit but I can try with another PC. I will inform you about result.

Do you have any issues running the starter application?

How you suggest I open a ticket to support and this is the solution:

Insert the module in the slot of the starter kit
Plug in the power supply to the starter kit
Plug in the usb cable between the computer and the starter kit
Start the firmware manager
Add the wanted firmware to the archive of the firmware manager.
Choose the module M40 category form the list in the firmware manger
Choose the firmware to flash on the module
Wait till the process is finished
Now you can restart the module.

Now it work!

1 Like