Firmware upgrade issues

I have an issues with an ewon flexy 205

When connected to the Flexy 205 via chrome we lose communications to the EWON for a couple of minutes, it appears to do this on a regular basis.
The firmware is 13.2s1, we have another EWON here for a customer project which has a later firmware version and this works OK with no communications issues.

I am using the Adm account to do the update.
first error received ‘transfer error: failed to send files to ewon failed’
The error logs are showing the following error – riftp-EBU (recovery) required for upgrade

Tried ticking the passive mode box – tried this and still the same error.

After downloading a recovery file from the support site.
While trying to do the recovery process the error, ‘This is not a recoverable Ewon model’

I do have a backup of this ewon if this is needed.


Since you are on 13.2s1 are you doing the pivot upgrade to 14.0s2 first before going to 14.3s0?

Yes we are performing them incrementally

Sorry for the delay. For the recovery file did the pcode match the last 2 digits of the serial number? Also was there a switch between the computer and Flexy with the ethernet connection in port 1? We could look at the backup to see what errors might be showing in the event log.