Flexy 201 not logging any historical information

I have a Flexy 201 that was on firmware 14.4s0PR, we tried to upgrade it to 14.5s1 but it failed and got stuck in a reboot loop. After 3 attempts to upgrade the firmware it finally succeeded, but ever since then we get no historical logging, nothing in the event log wither except for the System Booting entry. I have tried disabling the historical logging on a tag and re-enabling it to see if that would trigger something - but no luck. Any ideas how I can get this to start logging again?

Thank you

Can you share a screenshot of how the historical logging is configured on one of your tags?

Could you also capture a backup with support files for us to look at? This will give us access to the logs and configuration of the device so that we can pin down what’s happening here. To do this, open eBuddy, select the Ewon device you’d like help with, and click “Backup/Restore”. Make sure to check “include support files”, then click through to create a backup.

If you don’t have it, you can download eBuddy here: Ewon Technical Support - All Downloads

Hi Hugh,

Here is a screenshot and the backup


Can you try setting the logging interval to 1 and the deadband to -1? This will disable the deadband and log the tag’s value every second. I’d just like to make sure this isn’t an issue with the deadband preventing the logging from actually happening.

I did that and am still getting nothing in the historical - if you look at the event logs there is nothing in there either.

I see that. There aren’t any errors or anything, just the normal messages we’d expect when everything is working properly, plus what look like some messages logged from your scripts.

Can you try stopping the scripts and trying to log data with -1 deadband and 1 interval?

If you’re still having issues with the scripts stopped, I think a factory reset would be the next step. You can back up and restore your tags and scripts by connecting to your Ewon with FTP. You’ll just need to save var_list.csv and any .bas files, then copy them back over after the factory reset. Before fully configuring the Ewon I recommend trying to log to see if it works on a freshly-reset device.

Here are instructions on factory resetting the device. Note that this will completely erase your configuration, including tags and program, so please create a backup with eBuddy and manually back up the tag list and program through FTP ahead of resetting.

  • Power off the unit.
  • While powering it on, press & maintain the reset button. The LED labeled BI1 turns green.
  • Keep the reset button pressed for approximately 35 seconds until the USR LED remains red steady.
  • When this state is reached, release the button. The LED labeled BI1 turns off.
  • Check if the auto test is successful, the USR LED blinks red with a pattern of 200ms on and 1500ms off. The Ewon does NOT restart by itself in normal mode and remains running in this diagnostic mode.
  • Power off the Ewon and power it on again to reboot the unit in a normal mode. As described before, the Ewon returns to its default COM parameters and factory IP addresses (such as LAN after this level 2 reset is performed.

It is still not logging with the BASIC script turned off. I will do the reset and hopefully all will be well again.