Flexy 205 continual Resets

Hi Guys,

I have a flexy on a site that is to be alarmed in a matter of days for a project. This flexy was reseting multiple times a few weeks ago but I managed to fix it temporarily by changing the network from Automatic to 3G then set to 4G max. The error has started again where the modem resets every 17 minutes and is down for bout 10 minutes to the other sites.

Errors listed below:

try setting the gateway address manually to and

Hello Kyle,

@tedsch is correct. That will address the default gateway issue.

Are you enabling internet to any of the connect devices on the LAN? Can you supply a backup with support files of the unit? This can be done with using eBuddy.

Thanks, Ill try setting the gateway address. Yew the Ewon is allowing internet connection to two data loggers that send emails and FTP files to external servers.

Please find Support files below,


Set the DNS values on the connected equipment. Most times this solves the issue

What is the Cellular provider that you are using?

Thanks Kevin, would it be preferred for me to set the DNS_SERVER of the connected devices to the LAN I.P Address or the WAN I.P Address?

We are connected Telstra down here in Australia.

Another thing I thought could be one of the issues is the polling of two Modbus Servers to the Slave Devices. Is there a way to share a slave device? The other Modbus server is Citect Scada used for alarming and monitoring of the site.

FOr the DNS server, I would set it to a public server such as googles, &

THe LAN and WAN are not DNS servers, so they will not provide the solution we are looking for…

If you are using Modbus TCP, it is possible for multple masters to communicate with 1 slave. However, i would remove the second master to determine if it is causing the reboots.

Hi Kevin,

Yes both external devices are using a public server

I removed the secondary server and there are still reboots. I’m going to attempt a new modem or external antenna today. We had a cosy installed at this spot prior to the fleet and there weren’t any issues with it.


Since the NATitf is set to 2. Ensure the that the Gateway’s of the PLC’s are set to the LAN IP of the Flexy.

I would also update the MaxCallDur to 0 in the Comcfg. This can be done in the web page of the Flexy. The Max call duration forces the ewon unit to end the call after a configured time, and resestablish the cellular connection. Currently it is set to 10080. By setting it to 0, it will stop the ending the call.


Were you able to verify that the LAN Gateway IP’s of the connected devices are set to the LAN IP of the Flexy?

Hi Kevin,

Sorry I’ve been flat out with other things, the other devices have always been set to the Flexy’s lan IP address for the Gateway. I did notice that the DNS server was actually set to the same I.P address so I updated these to be

Further to this I visited site and replaced the modem expansion card and installed the high gain antenna to try and improve the signal quality it was ranging between 13 - 16 and now 15 - 21. This still did not resolve the issue.

My next point of call was to reduce the amount of data being sent through the EWON, which meant disabling one Citect Server and comms to MindSphere. Since I have done this the Flexy has been running for 6 days with no issue (Fingers Crossed), I have since re enabled the Citect Server and MindSphere communications. I will keep an eye on it for now, but I belive it is due to the poor 4G network on site and the data the is being pushed through the m2m network.

OK excellent.

I will keep this topic open for a few more days. Let me know if there are any changes