Flexy 205 Modbus RS485 not allowing more than 1 slave device to be read at a time

Hi, We have installed a Modbus serial card with our EWON Flexy 205 and have connected a modbus RS485 daisy-chain into port 1 (The chain has approx 12 devices on it) . We can read tags for each meter individually by settings up tags in the EWON or by using Modscan (using port forwarding and the EWON as the Modbus gateway).

When we look at the tags for the meters within the EWON, only tags for one meter reads correctly, the rest are in fault (All meter tags for two meters with different modbus IDs were made available in Topic A). As a test, if we move the tags for device ID15 to Topic B, enable Topic B and disable Topic A, the Topic B tags will read. We have tried changing Timeout/Polling intervals but no luck. Is there a way to poll multiple meters on the one dasiy-chain? Are we missing any settings which need to be added?


Yes, absolutely. There is no reason why this shouldn’t work up to 32 devices.

Yes, there must be something that is off. Do you have the termination resistors for the RS-485 bus. If not there could be issues with reflections on the bus, especially with a higher baud rate. You could check to see if it works at a lower one to test the theory.

Another thing to check is that you have the other slaves configured right. There are only 3 topics you can use so if you have 12 slaves, you will have to put their node addresses in the tag setting, not the topic setting. See Modbus IO Server (page 10) and Polling Data from MODBUS RTU. There is info in the last doc about how to troubleshoot the tags in error.

Make sure the extension card settings are correct as well. Refer to the Installation Guide.

Best Regards,

Kyle Reynolds