Flexy 205 slow down the polling for new changes on the PLC's


#1

I have all my tags setup to topic A (modbus) but changing the polling does not seem to slow down, I have rebooted.


#2

There is no slave address? How are you polling the device?


#4

I have the address in the tag itself:

image


#5

Set the slave address in the Topic A box above and then try changing the poll rate. If it’s not working, please make a backup with eBuddy and check “Include Support files” and attach that so I can check the logs and settings.

Thanks,

Kyle


#6

I have six different slaves and only 3 topics that why you guys said to do it in the tag area.


#7

I see. It looks like the poll rate you set isn’t getting transferred from the web interface into the device configuration file for some reason.

Can you provide an eBuddy Backup of the device with Support files?

Kyle


#8

yes [color=red]MOVED TO STAFF NOTE[/color] (355 KB)


#10

Thanks for that. It looks like the poll rate is set to 20 seconds for topic A, 2 seconds for B & C.

MbsPR1:20000
MbsPR2:2000
MbsPR3:2000

Is that what it was set at in the web interface when you made the backup? Are you making sure to reboot or restart the Modbus client after changing the poll rate?

How are you determining the poll rate?

Kyle


#11

I determin the rate as how fast my onchange event in basic is changing and watching the values on the flexy update the values. I did not know changing the poll rate the plc clients (modbus) had to be restarted. But I always reboot the flexy.


#12

Keep in mind that watching the values update in the browser window is not in real time and is probably not very accurate for measuring the poll rate. Try logging the data and then checking the poll rate that way.


#15

Hi @wizardontherun,

Alex said you are still having issues with the poll rates. If you have made any changes since you shared the backup in October, can you upload a new backup? Can you describe what you have tried and how you are determining the actual poll rate?

Thank you,

Kyle


#16

What do you have the timeout set to?

If the timeout is too low, it can cause a retry to be sent much quicker than the poll rate so I would recommend changing it to a value larger than the poll rate to see if that makes a difference.


#17

Have not changed anything, as we had ewon right the basic code to replace ours, polling rate is still the same. But does not seem to make a change on polling of the plc’s

I can give you access to unit as it is a test environment. 1 Flexy and 6 PLC’s

MOVED TO STAFF NOTE (392 KB)


#20

Sure, if you want to make a temp eCatcher account that I can use to access the device, or a Teamviewer ID & pw that would be helpful.


#21

Sure, team viewer ID:


#24

Hi Frank,

I was just talking to Alex about the Modbus polling on the Flexy going too fast again. Can you take a new backup with support files and send it to me so I can check where the settings are?

Thanks,
Kyle


#25

Hi Frank,

Somehow your last email to me got lost, and I just got it and looked at the logs. The poll rate is set to 8 seconds on Topic A and 2 seconds on B and C. What did you want it to be?

I don’t have a log in to the account, can you give me one so I can test it?

Thanks,

Kyle


#26

It is set to 8 sec, but if you watch the basic console it is changing way faster.


#28

I’ve been sitting here watching it and I’m only seeing it update about every 10 - 20 seconds. I don’t know if that’s because I’m remote and the connection is delayed, but if you want to increase it more we can.